Opened 10 years ago

Closed 6 years ago

Last modified 6 years ago

#5106 closed Bug report (wontfix)

modified date colum incorrect years.

Reported by: Yong Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version: XP

Description

I use Filezilla client 3.3.1 on XP.
I can view the ftp site through IE shows correct year but in Filezilla shows everything 2010 instead.

I attach picture as 1st screen print is from IE and 2nd screen print from Filzilla

Attachments (3)

date.bmp (22.0 KB) - added by Yong 10 years ago.
Scrren print of IE & Filezilla
Explorerview.png (16.4 KB) - added by Gerd 6 years ago.
This is what Explorer shows
FileZillaView.png (14.0 KB) - added by Gerd 6 years ago.
This is what FileZilla shows

Download all attachments as: .zip

Change History (11)

Changed 10 years ago by Yong

Attachment: date.bmp added

Scrren print of IE & Filezilla

comment:1 Changed 10 years ago by Tim Kosse

Status: newmoreinfo

Is both your computer's as well as the server's system time correctly synchronized with the official time?

Can you please attach a complete log with "Show raw directory listings" enabled in the settings dialog of FileZilla?

comment:2 Changed 10 years ago by Tanmoy

Status: moreinfonew

Hi I am facing the same problem as well. However the issue is limited to only when using secure ftp i.e over port 22 ..over port ftp 21 the directories seem to correctly displayed. I seem to have the same problem when using winscp version 4.2.2 (build 480) and port port 22.
One thing that I noticed and that may or may not be the root cause is that when using secure ftp "mtime" is executed and this is not executed when using ftp.

Even though the server time and the desktop time match you see this in the filzilla logs. The 1289734920 corresponds to sun nov 2010.
=============
2010-01-05 12:17:52 2516 2 Status: Calculating timezone offset of server...
2010-01-05 12:17:52 2516 2 Command: mtime "18559989-01"
2010-01-05 12:17:52 2516 2 Response: 1289734920
2010-01-05 12:17:52 2516 2 Trace: CSftpControlSocket::ListParseResponse(1289734920)
2010-01-05 12:17:52 2516 2 Status: Timezone offsets: Server: -31554000 seconds. Local: -18000 seconds. Difference: 31536000 seconds.
==============


FileZilla Client I am using


Version: 3.3.1

Build information:

Compiled for: i586-pc-mingw32msvc
Compiled on: x86_64-unknown-linux-gnu
Build date: 2010-01-03
Compiled with: i586-mingw32msvc-gcc (GCC) 4.2.1-sjlj (mingw32-2)
Compiler flags: -g -O2 -Wall -g -fexceptions

Linked against:

wxWidgets: 2.8.10
GnuTLS: 2.8.3

comment:3 Changed 10 years ago by Tim Kosse

Status: newmoreinfo

Let me repeat:

Is [...] your computer's [...] system time correctly synchronized with the official time?

comment:4 Changed 10 years ago by Tanmoy

Status: moreinfonew

Yes

comment:5 Changed 10 years ago by Tim Kosse

Status: newmoreinfo

Please attach a complete log with "Show raw directory listings" enabled on the debug page in the settings dialog.

comment:6 Changed 9 years ago by Gerd

Status: moreinfonew

I have the same problem with FileZilla 3.3.5.1, some filedates are shown one year more.

In debug-mode the directory listing show for example:
Auflistung: type=file;size=8724480;modify=20111209114100; abc.exe

the same file in IE:
12/09/2010 12:41 8,724,480 abc.exe

Other files in the same directory shows the right date.

comment:7 Changed 6 years ago by Alexander Schuch

Status: newmoreinfo

I do not see "abc.exe" in your screenshot.

Can you please provide unmodified logs with "raw directory listings" enabled? And can you please make a screenshot of what FileZilla actually shows for that directory?

Please use current version of FileZilla 3.7.0.1 for that. Thank you.

Changed 6 years ago by Gerd

Attachment: Explorerview.png added

This is what Explorer shows

Changed 6 years ago by Gerd

Attachment: FileZillaView.png added

This is what FileZilla shows

comment:8 Changed 6 years ago by Gerd

Resolution: wontfix
Status: moreinfoclosed

Now I use the latest Version of FileZilla, but the problem still exists.
In Attachment #1 (Explorerview.png) you can see, what File information I see in Windows Explorer. In Attachment #2 (FileZillaView.png) you see, what FileZilla shows.
I take a look in the Logfile and it seems, that the FTP-Server delivers the wrong Date/Time. So it seems not a Problem of FileZilla and you can close this Ticket.
Thanks for your advice.

Note: See TracTickets for help on using tickets.