Opened 10 years ago

Closed 8 years ago

Last modified 6 years ago

#5096 closed Bug report (fixed)

FileZilla client hangs when accessed under Remote Desktop session

Reported by: asmodeus Owned by:
Priority: normal Component: FileZilla Client
Keywords: Remote Desktop Cc:
Component version: Operating system type: Windows
Operating system version: Windows 7 Ultimate x64

Description

When under Remote Desktop session, attempt to bring FileZilla from the system tray will hang FileZilla.

Change History (15)

comment:1 Changed 10 years ago by Tim Kosse

Status: newmoreinfo

Unfortunately I am unable to reproduce this. Which Remote Desktop software are you using?

comment:2 in reply to:  1 Changed 10 years ago by asmodeus

Status: moreinfonew

Replying to codesquid:

Unfortunately I am unable to reproduce this. Which Remote Desktop software are you using?

Built-in Remote Desktop server on my PC and for the client - Jaadu RDP for iPhone.

comment:3 Changed 10 years ago by Never Best

I'd like to confirm this problem; it is very annoying.

To reproduce you can simply open up FileZilla client while you are at your computer. Go to another computer and RDC into your first computer. FileZilla is now unresponsive in your RDC session, and you are forced to kill the exe.

OS: Windows 7 Ultimate x64 - Latest Updates
OS Video Card: ATI Raedon HD5400 - Latest Drivers
RDC: Built in windows RDC. Connecting from a Windows XP Machine.
Filezilla Version Tested: 3.3.4.1

My own notes: I think I saw this exact same problem with a different wxWidgets application in the past but I forget which (I could be crazy)... As a result is may be a problem with a certain wxWidgets component used, or maybe wxWidgets in general. Something to consider after a developer has confirmed the problem.

comment:4 Changed 10 years ago by Tim Kosse

Status: newmoreinfo

I still cannot reproduce this. If I could it would probably only take 10 minutes to fix.

How many displays are connected to each machine and what are their display resolution? What are the color depths set to? Any DPI scaling enabled?

Do you have any third-party programs installed which integrate deeply into the system? Such as docks, toolbars, custom theming engines and so on?

comment:5 in reply to:  4 Changed 10 years ago by asmodeus

Replying to codesquid:

How many displays are connected to each machine and what are their display resolution? What are the color depths set to? Any DPI scaling enabled?

In my case, that's two displays: main 1920x1200x32 and secondary 1920x1080x32. No DPI scaling.

Do you have any third-party programs installed which integrate deeply into the system? Such as docks, toolbars, custom theming engines and so on?

All I can think of is Rainmeter, but it doesn't really fall into this category.

comment:6 Changed 10 years ago by Never Best

Status: moreinfonew

I also have two displays, main 1920x1200x32, secondary 1280x1024x32
RDC Session Resolution Changes to: 1280x1024x15 (15bit)

No DPI scaling. No third party integrated things I know of... I'm using ATI catalyst (latest version), so maybe if we are all on ATI cards that could be it?

Only third party programs running are PeerBlock and a G-Mail Gadget Checker, which I don't think can be affecting filezilla. Services running should be just default from initial install.

My FileZilla is the portable ".zip" version.

comment:7 in reply to:  6 Changed 10 years ago by asmodeus

Replying to NvrBst:

I also have two displays, main 1920x1200x32, secondary 1280x1024x32
RDC Session Resolution Changes to: 1280x1024x15 (15bit)

My sessions were from 800x600 to 1600x1200x8 if I'm not mistaken.

I'm using ATI catalyst (latest version), so maybe if we are all on ATI cards that could be it?

Nope, I had NVidia GTX280 at that time.

My FileZilla is the portable ".zip" version.

Mine is regular install.

comment:8 Changed 10 years ago by Tim Kosse

Status: newmoreinfo

Odd, so nothing in common it seems.

When this happens, what is the CPU usage of FileZilla?

comment:9 in reply to:  8 Changed 10 years ago by asmodeus

Replying to codesquid:

Odd, so nothing in common it seems.

When this happens, what is the CPU usage of FileZilla?

I don't remember that. Can't test right now, maybe NvrBst can help?

comment:10 Changed 9 years ago by Never Best

Status: moreinfonew

Sorry for the long delay. The CPU usage of FileZilla is 0% during the problem. It also looks to me as if the problem stops the transfers but I cannot be 100% sure.

I've also tried to reproduce the problem using a Windows XP Virtual Machine (VM running FileZilla, and I connect to it via RDC from the host Win7 machine); I am not able to reproduce the problem in this configuration. Not sure if this is because it is Win XP or because it is a VM.

If I run FileZilla on Windows 7 x64, and then connect with a Windows XP via RDC I can see the problem.

If I run FileZilla on Windows 7 x64, and then connect with a Windows Server 2008 via RDC I can see the problem.

Maybe it could be something to do with Aero and RDC's Disable Visual Styles?

My connection settings with RDC are as follows:

Display configuration: Fullscreen
Colors: High Color (15 bit)
Local devices and resources (Uncheck printers, Uncheck Smart Cards)
Performance: Modem (56 Kpbs); aka "Visual Styles" unchecked.

Everything else is default. Also note, I always have transfers active with filezilla when I notice the problem, not sure if this part is important though.

If I get some free time I can try making a Windows 7 VM and seeing if I can reproduce the problem with that, however, I don't have any handy at the moment.

Anything else I could provide?

comment:11 Changed 9 years ago by Tim Kosse

Status: newmoreinfo

Would it be possible to get remote access to your machine so that I can run a special build of FileZilla in the remote debugger?

comment:12 Changed 9 years ago by Never Best

I set up a Win7 x86 VM machine, but not able to reproduce the problem in there either which I find weird. My CPU doesn't support x64 VM's so I couldn't test x64.

I cannot give access to my main Win7 x64 computer at the moment :( I can play around with VM's, and if I get one reproducing the problem I can give you complete RDC access to it, but I haven't been able to reproduce it yet in them.

If you have a special filezilla able to log information or such, I can use that (I know not the same as a remote debugger), and provide all log files.

comment:13 Changed 8 years ago by Alexander Schuch

Can anyone still reproduce the problem with a current version of FileZilla?

comment:14 Changed 8 years ago by Never Best

Status: moreinfonew

I am no longer able to reproduce the problem on my machine, but, I've gotten a whole new computer and video card during this time; old computer is gone. I'm not sure if that is what solved the problem, or if it is something in the latest 3.5.3 filezilla.

NB

comment:15 Changed 8 years ago by Alexander Schuch

Resolution: fixed
Status: newclosed

Okay, so I consider this bug as fixed. If you encounter it again, please feel free to re-open this issue. Thanks.

Note: See TracTickets for help on using tickets.