Opened 10 years ago

Closed 10 years ago

Last modified 5 years ago

#5059 closed Bug report (rejected)

Problem downloading non-ascii filenames

Reported by: Jorge Bastos Owned by:
Priority: blocker Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version:

Description

Howdy,
I believe I've found some bugs with this matter, my steps are:

Test 1:
-Created a file with name: pois.. a á é ã lção.txt
-Used Windows commandline to upload the file
-Open FileZilla client to download the file, but, got this:

---
When i entered the directory to where i uploaded the file got:

Command: PASV
Response: 227 Entering Passive Mode (195,23,114,74,244,101).
Command: MLSD
Response: 150 Opening ASCII mode data connection for MLSD
Status: Invalid character sequence received, disabling UTF-8. Select UTF-8 option in site manager to force UTF-8.
Response: 226 Transfer complete
Status: Directory listing successful

When i try to download the file i get:

Command: RETR pois.. a á é ã lção.txt
Response: 550 pois.. a á é ã lção.txt: No such file or directory
Error: Critical error

but is i try to delete the file, it is able to do it:

Command: DELE pois.. a á é ã lção.txt
Response: 250 DELE command successful
---

Test 2:
-Created a file with name: aaaaaaaapois.. a á é ã lção.txt
-Uploaded with Windows command line, but i set this parameters:
ftp> quote opts utf8 on
200 UTF8 set to on
ftp> mput aaa*
200 PORT command successful
150 Opening BINARY mode data connection for aaaaaaaapois.. a ß Ú Ò lþÒo.txt
226 Transfer complete

-Tried to download it via Filezilla client, but when i entered the dir where the file was uploaded, i get the same:
Command: CWD /bugs
Response: 250 CWD command successful
Command: TYPE I
Response: 200 Type set to I
Command: PASV
Response: 227 Entering Passive Mode (195,23,114,74,246,167).
Command: MLSD
Response: 150 Opening ASCII mode data connection for MLSD
Status: Invalid character sequence received, disabling UTF-8. Select UTF-8 option in site manager to force UTF-8.
Response: 226 Transfer complete
Status: Directory listing successful

if i try to download it, it doesn't work like in test 1, but delete works aswell.

Command: RETR aaaaaaaapois.. a á é ã lção.txt
Response: 550 aaaaaaaapois.. a á é ã lção.txt: No such file or directory
Error: Critical error
Command: DELE aaaaaaaapois.. a á é ã lção.txt
Response: 250 DELE command successful

FileZilla versios is: 3.3.0.1

maybe Filezilla client, show not use the UTF8 option, or maybe:

-IT could exist an option, in configuration, to enable or disable the:
-When download fails, try to download the file without UTF8

An ideia that maybe could resolve this issue.

Change History (2)

comment:1 by Tim Kosse, 10 years ago

Resolution: rejected
Status: newclosed

Broken server. Using any encoding other than UTF-8 violates the FTP specifications.

Either upgrade to a proper server or refrain from using non-ASCII characters.

Read http://wiki.filezilla-project.org/Character_Set for details.

comment:2 by Pete, 5 years ago

this is still a "problem" caused by servers in 2015, but filezilla client could implement a work-around "solution" to satisfy users' needs.

Note: See TracTickets for help on using tickets.