Opened 11 years ago

Closed 3 years ago

#4961 closed Bug report (fixed)

File Server.xml: ver 0.9.33 - tags with multilines text are reformatted on a single line

Reported by: borgo Owned by:
Priority: normal Component: FileZilla Server
Keywords: config file, xml Cc:
Component version: Operating system type: Windows
Operating system version: Windows 2003 server

Description

I use FileZilla Server 0.9.33 beta
In file "File Server.xml" I use the tag CDATA like in the following example:

<Item name="Initial Welcome Message" type="string">
<![CDATA[
.....text
.....more text
.....more more text
]]>
</Item>

The problem is that fileZilla remove CDATA tag and reformat all my welcome message as one text line, as shown below

<Item name="Initial Welcome Message" type="string">.....text.....more text.....more more text<Item>

Regards

Andrea

Change History (4)

comment:1 by Tim Kosse, 11 years ago

Resolution: wontfix
Status: newclosed

CDATA isn't supported, not part of the schema. Try using \n for linebreaks.

comment:2 by borgo, 11 years ago

Resolution: wontfix
Status: closedreopened

No way with "\n" string nor with invisible char \n
The parser always format my text on a signle line.
With the 9.32 version all works right and the parser didn't format my config tag on a single line.

The bug is not the use of CDATA but the reformating behavior of the xml config file.

comment:3 by borgo, 11 years ago

Summary: File Server.xml: CDATA tag not parsed correctly on 0.9.33File Server.xml: ver 0.9.33 - tags with multilines text are reformatted on a single line

comment:4 by Kurt McKee, 3 years ago

Resolution: fixed
Status: reopenedclosed

The welcome message behavior appears to have been fixed in FileZilla Server 0.9.60. It is possible to insert newlines.

Note: See TracTickets for help on using tickets.