Opened 16 years ago

Last modified 16 years ago

#495 closed Bug report

Server fails when using a browser.

Reported by: moueen Owned by:
Priority: high Component: Other
Keywords: Cc: moueen, renhoek, Tim Kosse
Component version: Operating system type:
Operating system version:

Description

The server is set for a certain user name and password.
Server version 0.87 (latest)
Client version 2.2.1a (latest)

The Filezilla client is used to verify the proper function of
the server. Inaddition, a different FTP client also worked
fine.

When using Mozilla to login to the server, only the folders
but not the files show up.

When using Opera, the directory change fails whether by
clicking on "parent directory" or by going using the
browser back button and clicking on a different forlder.

In Internet Explorer, It is possible to browse the
directories, and to open images, but it is not possible to
drag an image or file from the IE window to the desktop
or other client folders.

The above findings were verified on two seperate
Win2000 PC as servers and several client PC (Win98,
WinNT, & Mac OSX)

Change History (4)

comment:1 Changed 16 years ago by moueen

The tested user privilages included:

+ read
+/- write

+ List
+ + Subdirs

+/- Resolve window shortcuts
+/- Show relative paths

comment:2 Changed 16 years ago by renhoek

Same for me. Windows XP Pro, Mozilla 1.5 and Filezilla
server 0.8.7

I looked, and it _does_ send over a file listing, but I
think Mozilla has trouble parsing it. I think that this is a
minor tweak to the output format of an 'ls'.

comment:3 Changed 16 years ago by renhoek

I checked.. doing a ftp under unix, so I can actually see
the listing, I run into this:

-xw-r--r-- 1 ftp ftp 37476 Nov 17 14:24 kol9.jpg
-xw-r--r-- 1 ftp ftp 34552 Nov 17 14:24 prr17.jpg

As you can see, that 'x' bit is wrong, and should be 'r'.
Not sure if Mozilla messes up because of it, but it seems
plausible.

I looked in the source 'Permissions.cpp', function
'CPermissions::GetDirectoryListing'. However this function
looks ok. I don't have VC so I cannot compile but I
recommend a few debug passes will sort this problem out in a
few minutes. :)

comment:4 Changed 16 years ago by Tim Kosse

This problem has already been fixed in the CVS version.
Version 0.8.8 will be released this weekend.

Note: See TracTickets for help on using tickets.