Opened 10 years ago

Closed 10 years ago

Last modified 6 years ago

#4897 closed Bug report (invalid)

Error: local: unable to open

Reported by: VR Owned by:
Priority: normal Component: FileZilla Client
Keywords: network drive read-only Cc: yaaang@…
Component version: Operating system type: Windows
Operating system version: XP SP3, 7 64-bit

Description

If I'm trying to copy files from SFTP server in my case (I guess from any server) directly to mapped network drive I get following symptoms:

Some files are transferred OK but then Filezilla Client hogs CPU time (whole machine becomes bit unresponsive) and after some timeout following error appears:

error while writing local file

and to some other files after this one:
local: unable to open Z:\dir\ec\to\rytree\file.end

Files with error are partially transferred and then stopped.

Like said error do not appear on all files. If I transfer files to my own hard drive everything works. This behavior appear with versions 3.2.8 and 3.2.8.1.
3.2.7.1 works correctly.

Attachments (1)

procmon.png (192.3 KB) - added by Yang Zhang 10 years ago.
Process Monitor capture

Download all attachments as: .zip

Change History (7)

comment:1 Changed 10 years ago by Tim Kosse

Status: newmoreinfo

Nothing has changed in the relevant parts of the code between 3.2.7.1 and 3.2.8(.1) that could possibly cause this.

Please try uninstalling all firewalls, virus scanners and so-called security solutions, they are the most likely cause for your problem. Does that fix your issues?

comment:2 Changed 10 years ago by VR

Status: moreinfonew

At least I can say that the possible error is in file fzsftp.exe. At first I tried to disable firewall (F-Secure) and tested with same symptoms. I'm not able/interested to completely uninstall firewall. But maybe this helps: I tried to manually copy old version fzsftp.exe from 3.2.7.1 to 3.2.8.1 and this error disappears.

comment:3 Changed 10 years ago by Tim Kosse

Resolution: rejected
Status: newclosed

Like I said before, nothing has changed between 3.2.7.1 and 3.2.8.1 that could possibly cause this. To be more specific, the only thing changed in the fzsftp component between those two versions is an increase of the socket advertised TCP window size, but that's in the networking code, it cannot affect opening of fils.

In other words, something on your system is preventing fzsftp to open the file. Since only 3.2.8.1 is affected it has to be some sort of software that is known for this kind of behavior. Thus: Uninstall all firewalls, virus scanners and so-called security solutions,

comment:4 Changed 10 years ago by Yang Zhang

Cc: yaaang@… added
Operating system version: XP SP3XP SP3, 7 64-bit
Priority: normalcritical
Resolution: rejected
Status: closedreopened
Summary: Error when transferring files from server directly to network driveError: local: unable to open

I'm seeing a similar problem on 3.2.8.1, except that I'm not even saving to a network drive, just a local drive. I verified using Process Explorer that handles to the files in question were not in use by any other process. I further verified that I can open, modify, rename, etc. the files in question.

FZ's exact error:

Command: get "main.py" "C:\Users\t-yanzh\Documents\work\os\Projects\netjail\policysrv\main.py"
Error: local: unable to open C:\Users\t-yanzh\Documents\work\os\Projects\netjail\policysrv\main.py
Status: Disconnected from server

I'm on Windows 7 64-bit.

comment:5 Changed 10 years ago by Tim Kosse

Priority: criticalnormal
Status: reopenedmoreinfo_reopened

Since you're using process explorer, what does Windows reply with if fzsftp.exe requests to open the file in question?

Changed 10 years ago by Yang Zhang

Attachment: procmon.png added

Process Monitor capture

comment:6 Changed 10 years ago by Yang Zhang

Keywords: read-only added
Resolution: invalid
Status: moreinfo_reopenedclosed

D'oh, user error. The problem was due to the file being marked as read-only.

Note: See TracTickets for help on using tickets.