Opened 10 years ago

Closed 10 years ago

#4839 closed Bug report (rejected)

.pureftpd files everywhere. prohibited filename.

Reported by: Jim Michaels Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc: jmichae3@…
Component version: Operating system type: Windows
Operating system version: XP Pro SP3

Description

I can't upload anymore. something new about the server is not allowing me to delete .pureftpd filenames, even though they are being created.

it is consuming all my web space, and I have some ISOs to upload.
my uploads take days to complete at 384kbps. so this may be causing filezilla to leave large garbage behind.

please change filezilla to remove the . in front. that should do it. Also, please fix the bug that leaves the trail of garbage on uploads that last several days. thanks.
thanks

by the way, it doesn't matter what ftp client I use, I can't delete them. I suppose that's a server issue.

Response: 226-Options: -a -l
Response: 226 32 matches total
Status: Directory listing successful
Command: DELE .pureftpd-upload.4abba5b4.15.3f38.11c65b03
Response: 550 Prohibited file name: .pureftpd-upload.4abba5b4.15.3f38.11c65b03
Command: DELE .pureftpd-upload.4abc2fc1.15.6400.30d4d7d2
Response: 550 Prohibited file name: .pureftpd-upload.4abc2fc1.15.6400.30d4d7d2
Command: DELE .pureftpd-upload.4abc66ee.15.3241.afbeae25
Response: 550 Prohibited file name: .pureftpd-upload.4abc66ee.15.3241.afbeae25
Command: DELE .pureftpd-upload.4abc9c9b.15.7eb4.2aeb9c4
Response: 550 Prohibited file name: .pureftpd-upload.4abc9c9b.15.7eb4.2aeb9c4
Command: DELE .pureftpd-upload.4abcd02a.15.5fb3.81dc8d4c
Response: 550 Prohibited file name: .pureftpd-upload.4abcd02a.15.5fb3.81dc8d4c
Command: DELE .pureftpd-upload.4abd03ba.15.3246.9aa1f088
Response: 550 Prohibited file name: .pureftpd-upload.4abd03ba.15.3246.9aa1f088
Command: DELE .pureftpd-upload.4abd8b2f.15.3fba.45d3f0d4
Response: 550 Prohibited file name: .pureftpd-upload.4abd8b2f.15.3fba.45d3f0d4
Command: DELE .pureftpd-upload.4abdc2bf.15.6c1.f67c19c
Response: 550 Prohibited file name: .pureftpd-upload.4abdc2bf.15.6c1.f67c19c
Command: DELE .pureftpd-upload.4abdf704.15.451e.dec536fd
Response: 550 Prohibited file name: .pureftpd-upload.4abdf704.15.451e.dec536fd
Command: DELE .pureftpd-upload.4abe2acf.15.102f.9f970a70
Response: 550 Prohibited file name: .pureftpd-upload.4abe2acf.15.102f.9f970a70
Command: DELE .pureftpd-upload.4abe603e.15.5d6e.acdf9b1
Response: 550 Prohibited file name: .pureftpd-upload.4abe603e.15.5d6e.acdf9b1
Command: DELE .pureftpd-upload.4abee99c.15.3ed1.1e24f4ba
Response: 550 Prohibited file name: .pureftpd-upload.4abee99c.15.3ed1.1e24f4ba
Command: DELE .pureftpd-upload.4abf1f7f.15.51b.d77a82ff
Response: 550 Prohibited file name: .pureftpd-upload.4abf1f7f.15.51b.d77a82ff
Command: DELE .pureftpd-upload.4abf534b.15.2497.bfd1d9de
Response: 550 Prohibited file name: .pureftpd-upload.4abf534b.15.2497.bfd1d9de
Command: DELE .pureftpd-upload.4abf8573.15.73fe.767fc320
Response: 550 Prohibited file name: .pureftpd-upload.4abf8573.15.73fe.767fc320
Command: DELE .pureftpd-upload.4abfb7d7.15.4224.7e25e803
Response: 550 Prohibited file name: .pureftpd-upload.4abfb7d7.15.4224.7e25e803
Command: DELE .pureftpd-upload.4ac253ea.15.739.5fe192b8
Response: 550 Prohibited file name: .pureftpd-upload.4ac253ea.15.739.5fe192b8
Command: DELE .pureftpd-upload.4ac28c0e.15.73c9.dee75fce
Response: 550 Prohibited file name: .pureftpd-upload.4ac28c0e.15.73c9.dee75fce
Command: DELE .pureftpd-upload.4ac2c53f.15.4fcd.ff142824
Response: 550 Prohibited file name: .pureftpd-upload.4ac2c53f.15.4fcd.ff142824

Change History (6)

comment:1 Changed 10 years ago by Tim Kosse

Priority: criticallow
Resolution: rejected
Status: newclosed

This is a problem with your server.

You need to contact your server administrator, he needs to remove the files manually for you.

comment:2 Changed 10 years ago by Jim Michaels

Resolution: rejected
Status: closedreopened

they said I need to use winscp instead, that filezilla is unreliable on files over 500MB.

comment:3 Changed 10 years ago by Tim Kosse

Resolution: rejected
Status: reopenedclosed

they said I need to use winscp instead, that filezilla is unreliable on files over 500MB.

That's bullshit.

Also, you are using FTP. Now guess where the FTP support in WinSCP comes from. It's directly taking from FileZilla, same code.

You should get a better hoster, yours obviously is clueless and making up nonsense excuses.

comment:4 Changed 10 years ago by Jim Michaels

Cc: jmichae3@… added
Priority: lownormal
Resolution: rejected
Status: closedreopened

I get a lot of dropped connections with filezilla. but curiously enough, lately the .pureftpd files seem to cut off right around at 700MB. does this have anything to do with filezilla? I am getting no resolution with my hosting. they just say "use winscp for large files" but I would rather use filezilla because I have a lot of them and it takes over a week to upload at 384kbps. my files are DVD ISOs. those used to work, but not any more as of 3.2.7.1.

again: please change the . in .pureftpd-upload.4abdf704.15.451e.dec536fd to an _ instead! I am sure this is the cause.
not all *nix servers like you putting config files in their directories, so they restrict things. I am surprised that the unix server even allowed the files to get there in the first place.

when an upload is stopped or connection is dropped, the .pureftpd file is left behind. there may be other circumstances which leave the files.

I am sure this would not be the case if an _ were used. sure, you wouldn't have the "file invisibility". but I would gladly trade the pureftpd file invisibility for losing the server headaches.

comment:5 Changed 10 years ago by Jim Michaels

please? :-)

comment:6 Changed 10 years ago by Tim Kosse

Resolution: rejected
Status: reopenedclosed

.pureftpd files are created by PureFTPD, access to those files through FTP is also blocked by PureFTPD. In short, there is nothing I can do, you need to contact the server administrator. Neither can I change the leading dot to an underscore, it's all done by the server.

This is not a problem with FileZilla but instead a broken or misconfigured server.

Note: See TracTickets for help on using tickets.