Opened 10 years ago

Closed 10 years ago

#4795 closed Bug report (rejected)

Filezilla doesn't allow me to upload files whose names contain special characters

Reported by: thiago Owned by:
Priority: critical Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version:

Description

Here is the log message:

Status: Listagem de diretórios bem sucedida
Status: Renomeando '/wwwroot/cieaa/cieaa_trabalhos2009/117_SIMPÓSIO_-_ANÁPOLIS_p_ENVIAR.doc' para '/wwwroot/cieaa/cieaa_trabalhos2009/117_SIMPÓSIO_-_ANPOLIS_p_ENVIAR.doc'
Comando: RNFR 117_SIMPÓSIO_-_ANÁPOLIS_p_ENVIAR.doc
Resposta: 550 "117_SIMPÓSIO_-_ANÁPOLIS_p_ENVIAR.doc": no such file or directory.

Here I try to rename this kind of files on me host. Filezilla answer me 'no such file or directory'. The same hapens if I try to upload the files that has special chars like 'ç~´' on their names.

I already tried to switch the transfer kind to ASCII but it didn't work.

If matters, my Fillezila language is portuguese(brazil).

(I tested doing the same operation with SmartFTP and it worked. Don't think I'm comparing both).

Thank you.

Change History (1)

comment:1 Changed 10 years ago by Tim Kosse

Resolution: rejected
Status: newclosed

You're server is broken, it is violating the FTP specifications by not using UTF-8 for non-ASCII characters.

Please read http://wiki.filezilla-project.org/Character_Set for further details.

You have two options: Either upgrade to a proper server or refrain from using non-English characters in filenames. Everything else is not covered by the specifications.

Note: See TracTickets for help on using tickets.