Opened 11 years ago

Closed 11 years ago

#4748 closed Bug report (rejected)

Failed to retrieve directory listing

Reported by: calimano Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version: vista x64

Description

I setup pureftpd and vsftpd on my test server and if I have pureftpd running (which uses MLSD for listings) and then stop and start vsftpd (which uses LIST for listings) it will give the following error on filezilla when trying to refresh the listing until filezilla is closed and reopened.

Command: CWD /test
Response: 250 Directory successfully changed.
Command: PWD
Response: 257 "/testing/22XX"
Command: PASV
Response: 227 Entering Passive Mode (61,122,21,12,27,22)
Command: MLSD
Response: 500 Unknown command.
Error: Failed to retrieve directory listing

As you can see it tries using MLSD even though vsftpd doesn't support MLSD.

Change History (1)

comment:1 by Tim Kosse, 11 years ago

Resolution: rejected
Status: newclosed

This is by design. Discovered features are cached by FileZilla, this vastly improves connection establishment times on subsequent connections. On the other hand changing server software is a very rare action. In this case the benefits greatly exceed the potential costs.

Note: See TracTickets for help on using tickets.