Opened 16 years ago

Last modified 14 years ago

#473 closed Bug report

SiteManager doesn't work with registry ?

Reported by: puddle Owned by:
Priority: normal Component: Other
Keywords: Cc: puddle, orangechicken, Tim Kosse, elsapo
Component version: Operating system type:
Operating system version:

Description

Pulled lastest FileZilla source version (2.2.1).

Tried to compile with MSVC6, failed (because FileZilla
uses headers not included with MSVC6), tried to compile
with MSVC.Net, succeeded.

Ran FileZilla.exe. It asked me whether to use the
registry, and said that registry is recommended for
multiuser environments, so I said yes.

I connected, transferred files, things look nice.

I went to Site Manager and configured a site, went to
Advanced to set the initial directory, Saved the
Settings, closed FileZilla.

Now every time I run FileZilla I get a corrupt xml error:

Error, can't parse 'FileZilla.xml', the file may be
corrupt.
For this session, the registry will be used to store
the settings.

and it doesn't remember the site I configured. I tried
the same thing again (except not recompiling the
source), and the same error happens.

Is SiteManager incompatible with registry settings ?

Change History (5)

comment:1 Changed 16 years ago by puddle

Windows version: Same problem manifesting on both Windows 98
and Windows XP (with same executable FileZilla.exe).

comment:2 Changed 16 years ago by puddle

I looked in the source for how OPTION_USEREGISTRY is used,
and the COptions::Init subroutine bails out (not looking for
an xml file) if it is 2, but, it never gets set to 2.

Should it get set to 2 ?

comment:3 Changed 14 years ago by orangechicken

SiteManager still doesn't seem to remember anything once
you've closed FileZilla (chose to store in registry).

comment:4 Changed 14 years ago by Tim Kosse

This bug report has been closed due to inactivity and has possibly
already been solved.

You can reopen this report if the issue still exists in the
latest version of FileZilla (Server).

comment:5 Changed 14 years ago by elsapo

This bug report has been closed due to inactivity

What more was I supposed to do? I looked in the source code,
and tried to diagnose the problem, and posted it below (as
you can see), but the developers never responded.

Note: See TracTickets for help on using tickets.