Opened 10 years ago

Last modified 10 years ago

#4698 reopened Bug report

Filenames including a : get stored as alternate data streams

Reported by: test Owned by:
Priority: normal Component: FileZilla Server
Keywords: alternate data stream, alternate data streams, ads, 0 byte file Cc:
Component version: Operating system type: Windows
Operating system version: NT onward (NTFS)

Description

When uploading from a client that supports a : in the filename, the FileZilla will accept the file for download, but will store anything after the : as an alternate data stream.

I'm not sure if this is a bug, or a feature.

It might be good to include a configuration toggle to disable this behaviour (i.e. send an invalid filename message to the sender) by default, as I found it very surprising.

Test case:

From a BSD, Mac or Linux box, create a file named "a:b". Upload the file. The server will show a 0 byte file named a, with an alternate data stream b with all of the content.

Change History (2)

comment:1 Changed 10 years ago by Tim Kosse

Resolution: duplicate
Status: newclosed

Duplicate of #3227

comment:2 Changed 10 years ago by test

Resolution: duplicate
Status: closedreopened

#3227 is for FileZilla client, this is for FileZilla server. Is it still a dupe?

Note: See TracTickets for help on using tickets.