Opened 10 years ago

Closed 10 years ago

#4684 closed Bug report (fixed)

Copy URL(s) to clipboard crashes with some unicode filenames

Reported by: andwoe Owned by: Tim Kosse
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type:
Operating system version: WinXP-SP3

Description

observed with FileZilla Client v3.2.6.1

When I use the "Copy URL(s) to clipboard" action in the context menu of the remote view, and the filename contains certain characters, e.g. "č", "ě" and many others -- possibly all of which are not in the active Windows code page (for me that is CP1252), the program crashes.

Change History (3)

comment:1 Changed 10 years ago by Tim Kosse

Owner: set to Tim Kosse
Status: newaccepted

Confirmed.

comment:2 Changed 10 years ago by Tim Kosse

This problem is caused by a problem in wxWidgets, see http://trac.wxwidgets.org/ticket/11014

comment:3 Changed 10 years ago by Tim Kosse

Resolution: fixed
Status: acceptedclosed

Please try the latest build from http://filezilla-project.org/nightly.php, it is linked against a patched wxWidgets.

Note: See TracTickets for help on using tickets.