Opened 12 years ago

Closed 12 years ago

Last modified 6 weeks ago

#4658 closed Bug report (worksforme)

Filezilla client freezes when you click on a directory with thousands of subdirectories

Reported by: Kelly Trimble Owned by:
Priority: normal Component: FileZilla Client
Keywords: too many subdirectories Cc:
Component version: Operating system type: Windows
Operating system version: XP

Description

I clicked on the + to expand a directory tree for a directory with around 2500 subdirectories. I then cliked on that directory and it listed the 2500 subdirectories in the lower pane. Each action took several seconds. Then I cliked on the next directory that had over 4,000 subdirectories. I thought it was just taking time to work, but after several minutes I realized the application had frozen. I intentionally crashed the program in Task Manager and then tried to relaunch. The program never came up. So I tried to launch the program again, and then again, still nothing. Then I realized that the Filezilla.exe was listed three times in Task manager processes, but not in applications, each instance was using about 11MB of memory. I rebooted the system, thinking that would clear it, but when I tried to launch again, it still never came up, but the exe was listed in Task Manager. I browsed around the registry to see if the program was using an obvious entry to tell it to go to the directory with 4,000 entries on open, but didn't find it. So I rebooted again and then uninstalled. I then turned around and re-installed. Same thing happened. I changed the name of the directory with 4,000 subdirectores and relaunched, no joy. Then I tried to change the name of the directory with 2,500 subdirectories, and explorer said it was being used by another program. I then re-crashed the sytem and was then able to rename the 2,500 subdir directory. I rebooted again (don't know why, just cautious I guess) and relaunched FileZilla. This time it came up. Interestingly, even though I uninstalled and re-installed, it still had all of my quickconnect entries from the initial install.

Change History (2)

comment:1 by Tim Kosse, 12 years ago

Resolution: worksforme
Status: newclosed

Are you using virus scanners? If so, uninstall them, they severely cripple performance.

I did a test with a directory containing 10k subdirectories, takes no more than 15 seconds to show all. I did some further optimization to bring it down to just below 10 seconds but more just isn't possible.

comment:2 by Rob190, 6 weeks ago

Frequent similar experiences but with far fewer files. Just experienced a 2 minute freeze trying to open a local directory with 115 image files. Killed Filezilla and restarted then no problem.
I'm running Malwarebytes which I know can cause these issues on many apps. Didn't appear to be a factor this time.

FileZilla Client


Version: 3.52.0.5

Build information:

Compiled for: x86_64-w64-mingw32
Compiled on: x86_64-pc-linux-gnu
Build date: 2021-01-08
Compiled with: x86_64-w64-mingw32-gcc (GCC) 8.3-win32 20190406
Compiler flags: -O2 -g -Wall -Wextra -pedantic -ffunction-sections -fdata-sections -Wno-cast-function-type

Linked against:

wxWidgets: 3.0.6
SQLite: 3.31.1
GnuTLS: 3.6.15

Operating system:

Name: Windows 10 (build 19041), 64-bit edition
Version: 10.0
Platform: 64-bit system
CPU features: sse sse2 sse3 ssse3 sse4.1 sse4.2 avx avx2 aes pclmulqdq rdrnd bmi bmi2 adx lm
Settings dir: C:\Users\robert\AppData\Roaming\FileZilla\

Note: See TracTickets for help on using tickets.