Opened 10 years ago

Closed 10 years ago

#4640 closed Bug report (fixed)

Ctrl-A does not deselect ".." item

Reported by: sirzooro Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version: XP SP3

Description

Steps to reproduce:

  1. Connect to FTP server
  2. Enter non-empty subdirectory
  3. Select ".." by clicking it
  4. Select all items by pressing Ctrl-A
  5. Try to drop selected items to left pane in order do download them

Expected result: FZ Client allows to drag them and adds them to download quene

Current result: FF Client either beeps or starts displaying square frame as while selecting multiple items with mouse

Version information:

FileZilla Client


Version: 3.2.6.1

Build information:

Compiled for: i586-pc-mingw32msvc
Compiled on: x86_64-unknown-linux-gnu
Build date: 2009-07-02
Compiled with: i586-mingw32msvc-gcc (GCC) 4.2.1-sjlj (mingw32-2)
Compiler flags: -g -O2 -Wall -g -fexceptions

Linked against:

wxWidgets: 2.8.10
GnuTLS: 2.8.1

Change History (2)

comment:1 Changed 10 years ago by Tim Kosse

Summary: Drag&Drop does not work after selecting with Ctrl-ACtrl-A does not deselect ".." item

The inability to use drag&drop with ".." selected is by design.

The real bug is that Ctrl+A does not deselect the ".." item.

comment:2 Changed 10 years ago by Tim Kosse

Resolution: fixed
Status: newclosed

Fix committed to the SVN repository. Ctrl+A will deselect the .. item in the next version.

Note: See TracTickets for help on using tickets.