Opened 10 years ago

Closed 10 years ago

#4633 closed Bug report (fixed)

FileZilla 3.2.6: GnuTLS issues w/ vsftpd 2.1.2

Reported by: Jim Knoble Owned by:
Priority: normal Component: FileZilla Client
Keywords: tls, mac padding, gnutls_priority_set Cc:
Component version: Operating system type: Windows
Operating system version: Windows Vista x64

Description

Client: FileZilla 3.2.6, prebuilt for Windows, linked against GnuTLS 2.8.1, running on Windows Vista x64.

Server: vsftpd-2.1.2, running on RHEL-4.8, linked against OpenSSL-0.9.7a. Connecting via FTPES.

FileZilla has no trouble establing control connection, but uploading/downloading files doesn't work. vsftpd says, "Failure reading network stream".

Found info about GnuTLS' random padding in TLSv1.0 packets here: http://www.gnu.org/software/gnutls/manual/html_node/On-Record-Padding.html . Turning off TLSv1 support in vsftpd (that is, SSLv3 is the only SSL/TLS protocol accepted) made downloads work, but uploads still don't work; they give the same message.

vsftpd logfile showing protocol exchange attached.

Both downloads and uploads work with FileZilla 3.2.5, prebuilt for Windows against GnuTLS 2.6.4, against exactly the same vsftpd server.

Attachments (1)

fz326-vsftpd212-log.txt (1.7 KB) - added by Jim Knoble 10 years ago.
vsftpd-2.1.2 protocol log of filezilla-3.2.6 session

Download all attachments as: .zip

Change History (2)

Changed 10 years ago by Jim Knoble

Attachment: fz326-vsftpd212-log.txt added

vsftpd-2.1.2 protocol log of filezilla-3.2.6 session

comment:1 Changed 10 years ago by Tim Kosse

Resolution: fixed
Status: newclosed

Already fixed in 3.2.6.1, caused by a bug in GnuTLS 2.8.x

I've posted a write-up at http://forum.filezilla-project.org/viewtopic.php?p=46325#p46325

Note: See TracTickets for help on using tickets.