Opened 10 years ago

Closed 6 years ago

Last modified 6 years ago

#4563 closed Bug report (outdated)

progress bar missing

Reported by: spilt Owned by:
Priority: normal Component: FileZilla Client
Keywords: progress bar missing Cc: vbrent, vsutra@…
Component version: Operating system type: Windows
Operating system version: windows xp sp3 32bit

Description

the progress bar is missing after I enque a large number of files (don't know if this is relevant). I've transferred many files before and always had a progress bar, so I can't say what I've done different this time. here's what it looks like:

http://img10.imageshack.us/img10/1598/progressbarmissing.jpg

this is the client version:
FileZilla Client


Version: 3.2.4.1

Build information:

Compiled for: i586-pc-mingw32msvc
Compiled on: x86_64-unknown-linux-gnu
Build date: 2009-04-27
Compiled with: i586-mingw32msvc-gcc (GCC) 4.2.1-sjlj (mingw32-2)
Compiler flags: -g -O2 -Wall -g -fexceptions

Dependencies:

wxWidgets: 2.8.10
GnuTLS: 2.6.4

Change History (7)

comment:1 Changed 10 years ago by vbrent

Cc: vbrent added

Same missing entire "progress line" or progress bar. Only happens after I first open filezilla after reboot of (virtual) computer. Doesn't happen all of the time, but most, and I have not yet isolated what makes it not happen. Happens with existing transfer list or adding new transfers to empty list. From one to 30 files in transfer list during these failures. Restart the filezilla program repairs the issue.

This happens with this version and a previously installed unknown version, probably 3.2.4.1.

XPsp3+, Virtual PC 2004

FileZilla Client


Version: 3.2.6.1

Build information:

Compiled for: i586-pc-mingw32msvc
Compiled on: x86_64-unknown-linux-gnu
Build date: 2009-07-02
Compiled with: i586-mingw32msvc-gcc (GCC) 4.2.1-sjlj (mingw32-2)
Compiler flags: -g -O2 -Wall -g -fexceptions

Linked against:

wxWidgets: 2.8.10
GnuTLS: 2.8.1

comment:2 Changed 10 years ago by Tim Kosse

Status: newmoreinfo

Can you reproduce this in the most recent version?

What graphics card do you have and which driver version?

comment:3 Changed 10 years ago by vsutra

Cc: vsutra@… added
Operating system version: windows xp sp3windows xp sp3 32bit
Status: moreinfonew

It is reproducible if you queue a number of files, scroll down until the last queued item is visible (and the first is not), and then start the queue transfer. (Only way to fix this is to stop the queue, scroll top, and start it again)

Also noticed that if you set file priority from highest to lowest, with the last queued item as highest and the first queued item as lowest (and high to low with everything in between), with large number of files inbetween, the transfer bar gets fubared (can't seem to fix this at all). Basically I think this problem will also be reproducible if one just makes sure the last item in the queue starts first.

I'm not sure whether this is relevant, I always run two transfers concurrently, however I'm not entirely sure whether that is a factor to be honest.

FileZilla Client


Version: 3.3.0.1

Build information:

Compiled for: i586-pc-mingw32msvc
Compiled on: x86_64-unknown-linux-gnu
Build date: 2009-11-15
Compiled with: i586-mingw32msvc-gcc (GCC) 4.2.1-sjlj (mingw32-2)
Compiler flags: -g -O2 -Wall -g -fexceptions

Linked against:

wxWidgets: 2.8.10
GnuTLS: 2.8.3

comment:4 Changed 10 years ago by vsutra

Some additional info...

For the second issue (where the transfer bar is broken when high priority is set to the last file), you can see the effects with the following image.

http://evilgods.net/fz-bug.png

You'll note there's only one visible transfer bar, and it's position is totally off, however there are two concurrent transfers, and I have no idea where the other transfer bar is at.

I did however notice that it is possible to fix this, by restarting filezilla, and making sure the top most queued item is visible, and then starting the queue transfer (as opposed to having the last queued item visible and the first not, which then causes this and the other issue).

comment:5 Changed 10 years ago by Simon

i can confirm latest build 3.3.1 having the same problem.. the bars missing
but also the last two entries were high priority as meantioned above so
perhaps the issue is there. oddily these used to be top of list but I closed filezilla
and reopened to find they moved in the queue.. click process queue to reactivate
the downloading.

comment:6 Changed 6 years ago by Alexander Schuch

Status: newmoreinfo

Do you still have that problem in FileZilla 3.7.1?

comment:7 Changed 6 years ago by Alexander Schuch

Resolution: outdated
Status: moreinfoclosed

No reply for more than 28 days.

Note: See TracTickets for help on using tickets.