Opened 11 years ago

Closed 11 years ago

#4394 closed Bug report (rejected)

When using SFTP mode with a passkey, FileZilla always asks for a password on every upload

Reported by: Eriol Owned by:
Priority: normal Component: FileZilla Client
Keywords: sftp password secureID passkey Cc:
Component version: Operating system type: Windows
Operating system version:

Description

I connect to a SFTP server where I have to use a secureID to generate a unique password. I create a site profile in Site Manager. I set "Servertype" to "SFTP-SSH File Transfer Protocol" and logon type to "Ask for Password." I put in my username and leave the password field blank.

When I log into the SFTP server, FileZilla asks for my password. I put in my secureID-generated password and choose "Remember my password for this session." Once I'm logged in, I try to upload a file, and FileZilla says, "Authentication Failed, Critical Error, Could Not Connect to Server" and asks me for a password again. I have to put in a new secureID-generated password to continue. I have to do this every time I upload, which does not make sense. I have tried other FTP clients and they remember the password for the session.

Please investigate this.

Change History (1)

comment:1 by Tim Kosse, 11 years ago

Resolution: rejected
Status: newclosed

Transfers use secondary connections so that you're still able to browse the server during transfers.

That you do get the additional password prompts is a sign that the Ask and Interactive logon types are working as intended.

Note: See TracTickets for help on using tickets.