Opened 12 years ago

Closed 12 years ago

#4203 closed Bug report (rejected)

FileZilla Server 'session' issue

Reported by: Drew J. Como Owned by:
Priority: low Component: FileZilla Server
Keywords: Cc:
Component version: Operating system type: Windows
Operating system version: Windows Server 2003R2 x32

Description

I recently ran into a problem with the latest version of FileZilla Server (0.9.30).

I use the 'Autoban' feature, which uses the default of 5 failed attempts and bans for 999 hours. One of my accounts had a problem where they were using the wrong password and their account was banned.

I went into the FileZilla Server interface and removed their IP from the filter list, however they were still blocked. I then clicked the lightening bolt icon to take the server offline and then put it back online. They were still banned.

I then went into the Windows Services and restarted the FileZilla Server service itself, which fixed the issue.

So, there is an underlying bug here, however even with that, shouldn't clicking the lightening bolt stop and start the service? (Right now it looks like there is another 'level' which doesn't need to be there.)

Change History (1)

comment:1 by Tim Kosse, 12 years ago

Priority: highlow
Resolution: rejected
Status: newclosed

This is by design. On a proper installation, the administration interface would not even have the permissions to start or stop services since it would not run under Administator account.

Note: See TracTickets for help on using tickets.