Opened 11 years ago

Closed 11 years ago

#4169 closed Bug report (rejected)

"Failed Transfer" bug

Reported by: Denis Kristanda Owned by:
Priority: normal Component: FileZilla Client
Keywords: failed transfer, too many connection Cc:
Component version: Operating system type: Windows
Operating system version: XP SP2

Description

If maximum number of session (set on the server) is exceeded and the client get error "530 Not logged in, too many connection" , the "Queue Items" was wrongly moved to "Failed Transfer Tab" (bug) => The client should maintain the queue until got the connection or get other error message.

There is a 'closed' bug about the same item but the solution is not really fixing the bug:
Ticket #3394: "Too many connections" wrongly marked "Failed Transfer"
http://trac.filezilla-project.org/ticket/3394

That bug is closed with remark "Increase the number of retries and the reconnect delay in the settings dialog to avoid this problem."

The solution is not really solution because say I increase 3 retries with delay 30s each (total 90s) to 10 retries with 60s delay (total 600s), then after 600s the same thing will happen (not fixing the problem, just delaying the problem)

I use client version 3.2.0 and still see this daily.

Here is how I recreate the problem easily:

  1. Say the server maximum session from the same ip address is 8.
  2. Place on the server a folder with hundreds of file (big and small: 1kb size to 500MB size), say 200 or more files (make sure the transfer will last long enough to observed). I call it "folder A"
  3. Make a second folder "folder B" on server: just copy of 'folder a"
  4. Download "folder A" with OTHER FTP CLIENT. (I use cuteftp 8.3.2) just make sure I use some of the session handler)
  5. Now connect FILEZILA (set delay and retry to minimum) to server and download "folder B"
  6. The "queued files" tab is filled with the file list, but soon enough they are wrongly moved to "Failed Transfer" tab.

This 'bug' is quite annoying because I transfer a big size quite frequently that usually takes 2-3 hours download and unattended. With this bug, after 3 hours I come back to the console only find that some of the files are on "Failed Transfer" tab and have to wait another 1 or 2 hours to complete that transfer.
(My current solution of this problem is to use cuteftppro that is not giving me the problem, but as open source fanatic I reckon FileZilla should be able to overcome this small problem - hope this can be solved before the trial period over.. ;-) )

NOTE: the problem is still occurring even only 1 client connect to the server (the above just to exaggerate) - the key is have to be a lot number of file with various mix of size

Thank you for the great product and great job for all the team !

LOG:
....
Response: 331 User name okay, need password.
Command: PASS
Response: 530 Not logged in, only 8 sessions from same IP allowed concurrently.
Error: Could not connect to server
Status: Resolving address of [domainname]
Status: Connecting to xx.xx.xx.xx:21...
Response: 150 Opening BINARY mode data connection for [filename] ([size] Bytes).
Status: Connection established, waiting for welcome message...
Response: 220 FTP Server ready...
Command: USER [username]
Response: 331 User name okay, need password.
Command: PASS
Response: 530 Not logged in, only 8 sessions from same IP allowed concurrently.
Error: Could not connect to server
Status: Resolving address of [domainname]
Status: Connecting to xx.xx.xx.xx:21...
Status: Connection established, waiting for welcome message...
Response: 220 FTP Server ready...
Command: USER [username]
Response: 331 User name okay, need password.
Command: PASS
Response: 530 Not logged in, only 8 sessions from same IP allowed concurrently.
Error: Could not connect to server
Status: Resolving address of [domainname]
Status: Connecting to xx.xx.xx.xx:21...
Status: Connection established, waiting for welcome message...
Response: 220 FTP Server ready...
Command: USER [username]
Response: 331 User name okay, need password.
Command: PASS
Response: 530 Not logged in, only 8 sessions from same IP allowed concurrently.
Error: Could not connect to server
Status: Resolving address of [domainname]
Status: Connecting to xx.xx.xx.xx:21...
Status: Connection established, waiting for welcome message...
Response: 220 FTP Server ready...
Command: USER [username]
Response: 331 User name okay, need password.
Command: PASS
Response: 530 Not logged in, only 8 sessions from same IP allowed concurrently.

.....

Change History (1)

comment:1 Changed 11 years ago by Tim Kosse

Resolution: rejected
Status: newclosed

There is no way to distinguish between a failed login attempt because of an incorrect password or because the server administrator is stupid and sets hideously low limits. The first digit of the error code is a 5, means fatal, do not retry.

If you cannot convince the server administrator to fix the configuration, you need to use a different server.

Note: See TracTickets for help on using tickets.