Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#4156 closed Bug report (rejected)

incorrect instantaneous speed

Reported by: Adelino Araujo Owned by:
Priority: normal Component: FileZilla Client
Keywords: instantaneous speed Cc:
Component version: Operating system type: Windows
Operating system version: Vista 32 Business

Description

The speed that I have on the transfer line is not correct. It presents the average speed of the total transfer and IT SHOULD BE THE INSTANTANEOUS speed.
If I limit the speed in 5 kb/second for exemple, this will drop so slowly, because it the average of the total transfer. And it is not correct.
I want the speed to drop to 5 kb immediately to show the current speed upload.
Ok, you could give average and instantaneous speed and that would be perfect!
But this way, it is not what I expected to see. So the remain time is affected by this value too.

And thank you for this amazing piece of art! I use client and server versions.

Change History (2)

comment:1 Changed 11 years ago by Tim Kosse

Resolution: rejected
Status: newclosed

This is by design. If you're on a busy connection where the momentary speed changes wildly, displaying the momentary speed will cause the remaining time to fluctuate wildly and be as reliable as the time remaining if copying files in Explorer.

The average speed and such remaining time based on this average speed are a far better indicators for the overall progress.

You can reset the average by stopping and resuming the queue.

comment:2 Changed 11 years ago by Adelino Araujo

At least I would like to choose in preferences the way I like it.

With average you look to the remain time and see like 2 hours. But the truth is that it will take more than 12 hours because there are more download going on, without you have notice it.

When you see the REAL speed, you can take measures or not, to check the line or another downloads and take some real action, for example, to prioritize your ftp.

The correct way should be for example: INST(4 kb/second) AVER(65kb/sec)

I wanna have some real idea when my upload will finish, not be fooled by the average and 5 hours late, realize that I forgot to close some torrents, to speed my ftp!

This is by design? Stop and resume? Think again!

Note: See TracTickets for help on using tickets.