Opened 11 years ago

Closed 7 years ago

Last modified 6 years ago

#4141 closed Bug report (fixed)

Problem with crashing when downloading folder/files very repeatable

Reported by: Kevin Fegan Owned by:
Priority: high Component: FileZilla Client
Keywords: crash downloading Cc: kevinf56@…
Component version: Operating system type: Windows
Operating system version: XP PRO

Description

Using Filezilla 3.2.0 (and also 3.1.6)
Windows XP PRO SP1 on AMD Athalon

Connection is FTP on port 21

Filezilla was working fine on prior version. Upgraded to 3.1.6 in December 2008 and began having some crashes. Upgraded to 3.2.0 today (2008-01-07) and still have problems crashing.

Crash happens nearly every-time I try to download (backup) the Plugins folder for a WordPress Blog. I initiate the download by dragging plugins folder from remote filelist to local filelist. The folder that is being copied does not exist on the local computer prior to initiating the download on Filezilla.

The folder has only 153 files, 16 folders, about 2.5 MB.

Crashes with other folders as well but this is the folder I am working on right now, and it is the folder being copied when the attached logfile was created.

When Filezilla crashes, perhaps 50% to 75% of the download is complete. I get a Windows crash message with these details:
AppName: filezilla.exe
AppVer: 3.2.0.0
ModName: msvcrt.dll
ModVer: 7.0.2600.1106
Offset: 00033de0

Filezilla USUALLY continues to run behind the Win-error box and sometimes it even completes the files in the queue before the Filezilla window closes.

Sometimes during this downloading, after the Win-error box opens, Filezilla will show a file-exists dialog indicating that a zero-length file already exists at the destination. Of course the file did not exist at the target location before the download because the target folder did not exist then and it was created by Filezilla.

Attachments (3)

filezilla-crash-part-1-of-3.log (203.5 KB) - added by Kevin Fegan 11 years ago.
Part 1 of 3 parts of Debug-log level 3
filezilla-crash-part-2-of-3.log (197.5 KB) - added by Kevin Fegan 11 years ago.
Part 2 of 3 parts of Debug-log level 3
filezilla-crash-part-3-of-3.log (139.5 KB) - added by Kevin Fegan 11 years ago.
Part 3 of 3 parts of Debug-log level 3

Download all attachments as: .zip

Change History (16)

Changed 11 years ago by Kevin Fegan

Part 1 of 3 parts of Debug-log level 3

Changed 11 years ago by Kevin Fegan

Part 2 of 3 parts of Debug-log level 3

Changed 11 years ago by Kevin Fegan

Part 3 of 3 parts of Debug-log level 3

comment:1 Changed 11 years ago by Kevin Fegan

Cc: kevinf56@… added

comment:2 Changed 11 years ago by Tim Kosse

Priority: normalhigh
Status: newmoreinfo

comment:3 in reply to:  2 Changed 11 years ago by Kevin Fegan

Replying to codesquid:

Please try this special build: http://filezilla-project.org/nightlies2/2009-01-08/i586-mingw32msvc/FileZilla_3_setup.exe

Does it still crash?

Hi,

Thanks so much for the quick reply.

I downloaded the special build and ran it. It says:
"Already Installed"
"Choose the maintenance option to perform."
"FileZilla 3.2.0 is already installed. Select the operation you want to perform and click Next to continue."

and it gave me 2 install options:
1) "Add/Remove/Reinstall components"
2) "Uninstall FileZilla"

I was expecting to install the "special build" in its own folder, or to update it over the existing FileZilla 3.2.0

I guess I'm not sure the best way to do this ...

Should I choose: Add/Remove/Reinstall components, or
Should I Uninstall FileZilla 3.2.0 then install the "special build"

How can I make sure my site-definitions and settings are preserved ?

Thanks

Kevin

comment:4 Changed 11 years ago by Tim Kosse

Just reinstall with the special build, your settings and sites remain unharmed.

comment:5 in reply to:  4 Changed 11 years ago by Kevin Fegan

Replying to codesquid:

Just reinstall with the special build, your settings and sites remain unharmed.

Ok, I reinstalled (special build) and tried the download again.

The first time it completed the download just fine.

The second time, it crashed. As it has happened sometimes before, FileZilla continued to run behind the Win-error message box.

Also like it has done sometimes before, during the downloading, after the Win-error box opens, FileZilla opened a file-exists dialog indicating that a zero-length file already exists at the destination. Of course the file did not exist at the target location before the download because the target folder did not exist then and it was created by FileZilla. It complained of 3 or 4 existing files and I answered overwrite each time.

The details from the Win-error box showed:
AppName: filezilla.exe AppVer: 3.2.0.0 ModName: msvcrt.dll
ModVer: 7.0.2600.1106 Offset: 00033de0

After the download completed, and after FileZilla and the Win-error message box was closed, I compared the files downloaded by FileZilla and confirmed that even though there was an error, FileZilla downloaded all files correctly.

I saved the log file from the crashed download (Debug-log level 3), and I can send it to you if you need it ... just let me know how to send it.

Thanks again,

Kevin

comment:6 Changed 11 years ago by Tim Kosse

For further analysis you need a debugger. Seems complicated but is in fact very easy. Please download http://downloads.sourceforge.net/mingw/gdb-6.8-mingw-3.tar.bz2?modtime=1208982015&big_mirror=1

Extract the contained gdb.exe into the FileZilla directory and start it. Enter these two commands:
file filezilla.exe
run

Once it crashes, gdb will tell you when FZ has crashed. Enter this:
bt

also do this:
thread apply all bt

Please attach the complete output of gdb to this ticket.

comment:7 in reply to:  6 Changed 11 years ago by Kevin Fegan

Replying to codesquid:

For further analysis you need a debugger. Seems complicated but is in fact very easy. Please download http://downloads.sourceforge.net/mingw/gdb-6.8-mingw-3.tar.bz2?modtime=1208982015&big_mirror=1
...

I ran the debugger with filezilla.exe. Unfortunately, I was not able to get it to crash ... perhaps that tells you something useful.

I downloaded the same folder as before, about 150 files, and it finished them without crashing. Then I did it a few times with a few other folders, with as much as 3000 files and it fished them without crashing as well.

I closed FileZilla and the debugger and tried FileZilla by itself ... it crashed with about 20 files downloaded and 130 in the queue. I tried it again, another crash. Then I tried it again with the debugger, twice more without a crash.

This is all with the special build version of 3.2.0.

So, right now, it never crashes, even with large file-sets, when using the debugger, and nearly always crashes with small file-sets when not using the debugger.

Please let me know if you have any other suggestions to try.

Thanks for all your help.

Kevin

comment:8 Changed 11 years ago by Tim Kosse

This is very annoying :(

Seems to be a race condition somewhere since it gets harder to reproduce if the timing changes. Please keep trying a few more times.

What CPU exactly do you have?

comment:9 in reply to:  8 Changed 11 years ago by Kevin Fegan

Status: moreinfonew

Replying to codesquid:

This is very annoying :(

Seems to be a race condition somewhere since it gets harder to reproduce if the timing changes. Please keep trying a few more times.

I'll keep trying it with the degugger and let
you know if/when it fails.

What CPU exactly do you have?

AMD Athlon Processor, 800 Mhz

Thanks for all the help.

Kevin

comment:10 Changed 11 years ago by Tim Kosse

Status: newmoreinfo

Are you using any firewalls, virus scanners or so-called security solutions? What happens if you uninstall [*] them? Does FileZilla still crash?

[*] Note that you cannot just disable them through their GUI. Doing so leaves their potentially broken drivers loaded. You have to fully remove them.

comment:11 Changed 7 years ago by Alexander Schuch

Do you still have that problem with FileZilla 3.5.3?

comment:12 Changed 7 years ago by Kevin Fegan

Status: moreinfonew

I am using version 3.5.2 and I am no longer having crashing issues, although I have not used FileZilla in a long time. I would say it is OK to close this ticket. I will update FZ to 3.5.3 and if there are any issues, I will open new ticket.

comment:13 Changed 7 years ago by Kevin Fegan

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.