Opened 11 years ago

Closed 11 years ago

#3785 closed Bug report (rejected)

Rename file sometimes makes filelist items unselectable

Reported by: dirTdogE Owned by:
Priority: normal Component: FileZilla Client
Keywords: rename, lock Cc: dirTdogE@…
Component version: Operating system type: Linux
Operating system version: Fedora 9

Description

Maybe once in every 5-10 times I rename a file, I will lose the ability to select/highlight, etc. the files in either the remote or local pane. At this point, Filezilla becomes unusable. The only way to recover is to relaunch the program or to disconnect and then reconnect.

This issue may have started with Filezilla version 3.

Change History (6)

comment:1 Changed 11 years ago by Tim Kosse

Status: newmoreinfo

Which version of FileZilla are you using?

comment:2 Changed 11 years ago by dirTdogE

Cc: dirTdogE@… added
Status: moreinfonew

3.1.0.1

comment:3 Changed 11 years ago by Tim Kosse

Status: newmoreinfo

Are you using the official binaries from filezilla-project.org or the packages provided by your distribution? In the latter case, which wxWidgets version do you have installed?

comment:4 Changed 11 years ago by dirTdogE

Status: moreinfonew

I am using the packages from Fedora. Umm ... I'm not entirely sure. Would you be referring to wxGTK-2.8.7-2.fc9 ("GTK2 port of the wxWidgets GUI library")? That's the closest thing I could find?

But I also noticed there I have compat-wxGTK26-2.6.4-2 ("GTK2 port of the wxWidgets GUI library") installed. If these two packages are indeed related to what you're talking about, maybe FZ only found the old version?

I've actually just now uninstalled the compat version since nothing else depended upon it. If you have no further comment, I guess I'll just let you know if the problem persists.

comment:5 Changed 11 years ago by dirTdogE

It's still happening, but I believe I may have discovered what is causing the inconsistency. If I press enter when I am finished entering the new file name, it appears that this error does not occur. However, if I use my mouse to "click off of" the file, the error does occur.

comment:6 Changed 11 years ago by Tim Kosse

Resolution: rejected
Status: newclosed

Most likely just a focus issues caused by a bug in wxWidgets. The focus handling has been improved in wxWidgets since 2.8.7. If you upgrade to wxWidgets 2.8.8 (or better, 2.8.9), this issue should go away.

Note: See TracTickets for help on using tickets.