Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#3779 closed Bug report (rejected)

FileZilla Client 3.1.2 crashes after connecting to FTP server

Reported by: Nico R. Owned by:
Priority: normal Component: FileZilla Client
Keywords: crash, segfault, wxGTK, wxPython, CFtpControlSocket Cc:
Component version: Operating system type: Linux
Operating system version:

Description

FileZilla Client 3.1.2 segfaults shortly after it has connected to an FTP server.

I don’t think this is important, but the last lines I can read in the log window are:

TYPE I
200 Switching to Binary mode.
PASV

This part of my gdb session should be helpful for those who understand it …:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb62b9710 (LWP 7323)]
0xb79c9e51 in subcolor () at /usr/src/debug/x11-libs/wxGTK-2.8.8.1/wxPython-src-2.8.8.1/src/regex/regc_color.c:356
356             co = GETCOLOR(cm, c);
(gdb) bt
#0  0xb79c9e51 in subcolor () at /usr/src/debug/x11-libs/wxGTK-2.8.8.1/wxPython-src-2.8.8.1/src/regex/regc_color.c:356
#1  0xb79cacc8 in onechr () at /usr/src/debug/x11-libs/wxGTK-2.8.8.1/wxPython-src-2.8.8.1/src/regex/regcomp.c:1552
#2  0xb79cc06b in parsebranch () at /usr/src/debug/x11-libs/wxGTK-2.8.8.1/wxPython-src-2.8.8.1/src/regex/regcomp.c:847
#3  0xb79cbd7f in parse () at /usr/src/debug/x11-libs/wxGTK-2.8.8.1/wxPython-src-2.8.8.1/src/regex/regcomp.c:624
#4  0xb79cc745 in parsebranch () at /usr/src/debug/x11-libs/wxGTK-2.8.8.1/wxPython-src-2.8.8.1/src/regex/regcomp.c:885
#5  0xb79cbd7f in parse () at /usr/src/debug/x11-libs/wxGTK-2.8.8.1/wxPython-src-2.8.8.1/src/regex/regcomp.c:624
#6  0xb79ce657 in wx_re_comp () at /usr/src/debug/x11-libs/wxGTK-2.8.8.1/wxPython-src-2.8.8.1/src/regex/regcomp.c:372
#7  0xb796e40d in wxRegExImpl::Compile (this=0x8838840, expr=@0xbfd51d94, flags=0) at /usr/src/debug/x11-libs/wxGTK-2.8.8.1/wxPython-src-2.8.8.1/src/common/regex.cpp:296
#8  0xb796e5b9 in wxRegEx::Compile (this=0xbfd51d64, expr=@0xbfd51d94, flags=0) at /usr/src/debug/x11-libs/wxGTK-2.8.8.1/wxPython-src-2.8.8.1/src/common/regex.cpp:625
#9  0x08182474 in CFtpControlSocket::ParsePasvResponse (this=0x8875d20, pData=0x8826000) at ftpcontrolsocket.cpp:3655
#10 0x08182e6a in CFtpControlSocket::TransferParseResponse (this=0x8875d20) at ftpcontrolsocket.cpp:3906
#11 0x0818c478 in CFtpControlSocket::ParseLine (this=0x8875d20, line={<wxStringBase> = {static npos = 4294967295, m_pchData = 0xbfd51ea0}, <No data fields>})
    at ftpcontrolsocket.cpp:385
#12 0x0818d002 in CFtpControlSocket::OnReceive (this=0x8875d20) at ftpcontrolsocket.cpp:287
#13 0x08170c6b in CRealControlSocket::OnSocketEvent (this=0x8875d20, event=@0x882c610) at ControlSocket.cpp:979
#14 0xb791e9a8 in wxAppConsole::HandleEvent (this=0x8343b80, handler=0x8875d20, func=&virtual table offset 136, event=@0x882c610)
    at /usr/src/debug/x11-libs/wxGTK-2.8.8.1/wxPython-src-2.8.8.1/src/common/appbase.cpp:322
#15 0xb79bcdea in wxEvtHandler::ProcessEventIfMatches (entry=@0x824d400, handler=0x8875d20, event=@0x882c610)
    at /usr/src/debug/x11-libs/wxGTK-2.8.8.1/wxPython-src-2.8.8.1/src/common/event.cpp:1231
#16 0xb79bdfe4 in wxEventHashTable::HandleEvent (this=0x824d500, event=@0x882c610, self=0x8875d20)
    at /usr/src/debug/x11-libs/wxGTK-2.8.8.1/wxPython-src-2.8.8.1/src/common/event.cpp:906
#17 0xb79be0eb in wxEvtHandler::ProcessEvent (this=0x8875d20, event=@0x882c610) at /usr/src/debug/x11-libs/wxGTK-2.8.8.1/wxPython-src-2.8.8.1/src/common/event.cpp:1293
#18 0xb79bd269 in wxEvtHandler::ProcessPendingEvents (this=0x8875d20) at /usr/src/debug/x11-libs/wxGTK-2.8.8.1/wxPython-src-2.8.8.1/src/common/event.cpp:1191
#19 0xb791ed21 in wxAppConsole::ProcessPendingEvents (this=0x8343b80) at /usr/src/debug/x11-libs/wxGTK-2.8.8.1/wxPython-src-2.8.8.1/src/common/appbase.cpp:294
#20 0xb7c25a01 in wxAppBase::ProcessIdle (this=0x8343b80) at /usr/src/debug/x11-libs/wxGTK-2.8.8.1/wxPython-src-2.8.8.1/src/common/appcmn.cpp:435
#21 0xb7b76003 in wxapp_idle_callback () at /usr/src/debug/x11-libs/wxGTK-2.8.8.1/wxPython-src-2.8.8.1/src/gtk/app.cpp:206
#22 0xb6fc9ae1 in g_idle_dispatch () at gmain.c:4090
#23 0xb6fcbb08 in g_main_context_dispatch () at gmain.c:2012
#24 0xb6fcf333 in g_main_context_iterate () at gmain.c:2645
#25 0xb6fcf82a in g_main_loop_run () at gmain.c:2853
#26 0xb73367c9 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#27 0xb7b8fa75 in wxEventLoop::Run (this=0x8804b48) at /usr/src/debug/x11-libs/wxGTK-2.8.8.1/wxPython-src-2.8.8.1/src/gtk/evtloop.cpp:76
#28 0xb7c2586e in wxAppBase::MainLoop (this=0x8343b80) at /usr/src/debug/x11-libs/wxGTK-2.8.8.1/wxPython-src-2.8.8.1/src/common/appcmn.cpp:312
#29 0xb7c25441 in wxAppBase::OnRun (this=0x230) at /usr/src/debug/x11-libs/wxGTK-2.8.8.1/wxPython-src-2.8.8.1/src/common/appcmn.cpp:367
#30 0xb7957e9a in wxEntry (argc=@0xb7a258ac, argv=0x8343c38) at /usr/src/debug/x11-libs/wxGTK-2.8.8.1/wxPython-src-2.8.8.1/src/common/init.cpp:460
#31 0xb7958087 in wxEntry (argc=@0xbfd52330, argv=0xbfd523b4) at /usr/src/debug/x11-libs/wxGTK-2.8.8.1/wxPython-src-2.8.8.1/src/common/init.cpp:472
#32 0x080a8a3e in main (argc=1, argv=0xbfd523b4) at locale_initializer.cpp:83

Change History (5)

comment:1 Changed 11 years ago by Tim Kosse

Status: newmoreinfo

Are you using the ANSI or the Unicode build of wxWidgets? Has your copy of wxWidgets been patched in any way compared to the official sources available from http://wxwidgets.org ?

comment:2 Changed 11 years ago by Nico R.

Status: moreinfonew

I am using x11-libs/wxGTK-2.8.8.1 from Gentoo. This is a Unicode build. The ebuild for this package is http://sources.gentoo.org/viewcvs.py/gentoo-x86/x11-libs/wxGTK/wxGTK-2.8.8.1.ebuild?rev=1.1&view=raw.

The sources are changed by the following patches:

  • wxGTK-2.6.3-unicode-odbc.patch
  • wxGTK-2.8.8-collision.patch
  • wxGTK-2.8.6-wxrc_link_fix.patch
  • wxGTK-2.8.7-mmedia.patch

The patches can be found at http://sources.gentoo.org/viewcvs.py/gentoo-x86/x11-libs/wxGTK/files/.

The patches mostly tackle the build system, and none of them looks like it could be the cause for a segfault while running the FileZilla Client. Might this be a wxWidgets bug?

comment:3 Changed 11 years ago by Tim Kosse

Status: newmoreinfo

Please attach the output of emerge --info

comment:4 Changed 11 years ago by Nico R.

Status: moreinfonew

emerge --info? Nothing unusual in the output. Although I cannot reproduce the output from back at the time wxGTK was built.
Anything special to look for?

After a few emerge runs, I found out that the bug only appears if wxGTK is compiled with -ftree-loop-linear in CFLAGS/CXXFLAGS. So can we assume a bug in wxGTK or gcc(-4.3.1)? Or is this an overhasty conclusion?

comment:5 Changed 11 years ago by Tim Kosse

Resolution: rejected
Status: newclosed

Most likely GCC bug. It is a well-known fact that non-default optimizations can be dangerous. Don't use them.

Note: See TracTickets for help on using tickets.