Opened 11 years ago

Closed 11 years ago

Last modified 5 years ago

#3774 closed Bug report (rejected)

Can't set transfers timeout value.

Reported by: Oscar Owned by:
Priority: normal Component: FileZilla Client
Keywords: transfers timeout Cc: pesuke@…
Component version: Operating system type: Windows
Operating system version: XP SP2

Description

System:

AMD Athlom 64 X2 Dual
Windows XP Profesional SP2
Filezilla 3.1.2

Bug:

If I change the value in Edit->Options->Transfers->Timeout. Filezilla does not take this value and reconnect again if the session is idle 20 seconds.

When I set 0 value to disable the timeout of file transfers. Filezilla do the same again.

ScreenShot:

Attachments (1)

s1.jpg (48.7 KB) - added by Oscar 11 years ago.
Transfers Timeout

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by Oscar

Attachment: s1.jpg added

Transfers Timeout

comment:1 Changed 11 years ago by Oscar

Cc: pesuke@… added

comment:2 Changed 11 years ago by Tim Kosse

Priority: highnormal
Status: newmoreinfo

The contents of the message log would be nice.

comment:3 Changed 11 years ago by Oscar

Status: moreinfonew

My ftp server session timeout is 6000 and data transfer timeout is 2200 and Filezilla configuration is like screenshot.

If i do the same with windows/linux ftp command or IExplorer 7, does not reconnect every transfer file.

20:07:30 Status: Resolving address of x
20:07:30 Status: Connecting to x
20:07:30 Status: Connection established, waiting for welcome message...
20:07:30 Response: 220 (vsFTPd 2.0.6)
20:07:30 Command: USER root
20:07:30 Response: 331 Please specify the password.
20:07:30 Command: PASS
20:07:30 Response: 230 Login successful.
20:07:30 Command: SYST
20:07:30 Response: 215 UNIX Type: L8
20:07:30 Command: FEAT
20:07:30 Response: 211-Features:
20:07:30 Response: EPRT
20:07:30 Response: EPSV
20:07:30 Response: MDTM
20:07:30 Response: PASV
20:07:30 Response: REST STREAM
20:07:30 Response: SIZE
20:07:30 Response: TVFS
20:07:30 Response: UTF8
20:07:30 Response: 211 End
20:07:30 Command: OPTS UTF8 ON
20:07:30 Response: 200 Always in UTF8 mode.
20:07:30 Status: Connected
20:07:30 Status: Retrieving directory listing...
20:07:30 Command: PWD
20:07:31 Response: 257 "/usr/home/root"
20:07:31 Command: TYPE I
20:07:31 Response: 200 Switching to Binary mode.
20:07:31 Command: PASV
20:07:31 Response: 227 Entering Passive Mode (x)
20:07:31 Command: LIST
20:07:31 Response: 150 Here comes the directory listing.
20:07:31 Response: 226 Directory send OK.
20:07:31 Command: PASV
20:07:31 Response: 227 Entering Passive Mode (x)
20:07:31 Command: LIST -a
20:07:31 Response: 150 Here comes the directory listing.
20:07:31 Response: 226 Directory send OK.
20:07:31 Status: Calculating timezone offset of server...
20:07:31 Command: MDTM .bash_history
20:07:31 Response: 213 20080916134309
20:07:31 Status: Timezone offsets: Server: 0 seconds. Local: 7200 seconds. Difference: 7200 seconds.
20:07:31 Status: Directory listing successful
20:08:30 Status: Resolving address of x (I make a transfer after 1 minute)

20:08:30 Status: Connecting to x...
20:08:30 Status: Connection established, waiting for welcome message...
20:08:30 Response: 220 (vsFTPd 2.0.6)
20:08:30 Command: USER root
20:08:30 Response: 331 Please specify the password.
20:08:30 Command: PASS

20:08:30 Response: 230 Login successful.
20:08:30 Command: OPTS UTF8 ON
20:08:30 Response: 200 Always in UTF8 mode.
20:08:30 Status: Connected
20:08:30 Status: Starting upload of C:\aplicaciones\dopdf.exe
20:08:30 Command: CWD /usr/home/root
20:08:30 Response: 250 Directory successfully changed.
20:08:30 Command: PWD
20:08:30 Response: 257 "/usr/home/root"
20:08:30 Command: TYPE I
20:08:30 Response: 200 Switching to Binary mode.
20:08:30 Command: PASV
20:08:30 Response: 227 Entering Passive Mode (x)
20:08:30 Command: STOR dopdf.exe
20:08:30 Response: 150 Ok to send data.
20:08:39 Response: 226 File receive OK.
20:08:39 Status: File transfer successful
20:09:09 Status: Disconnected from server (Here disconnect)
20:09:40 Status: Resolving address of x
20:09:40 Status: Connecting to x...
20:09:40 Status: Connection established, waiting for welcome message...
20:09:40 Response: 220 (vsFTPd 2.0.6)
20:09:40 Command: USER root
20:09:40 Response: 331 Please specify the password.
20:09:40 Command: PASS
20:09:40 Response: 230 Login successful.
20:09:40 Command: OPTS UTF8 ON
20:09:40 Response: 200 Always in UTF8 mode.
20:09:40 Status: Connected
20:09:40 Status: Starting upload of C:\aplicaciones\Kqemu-1.3.0pre11-install.exe
20:09:40 Command: CWD /usr/home/root
20:09:40 Response: 250 Directory successfully changed.
20:09:40 Command: TYPE I
20:09:40 Response: 200 Switching to Binary mode.
20:09:40 Command: PASV
20:09:40 Response: 227 Entering Passive Mode (x)
20:09:40 Command: STOR Kqemu-1.3.0pre11-install.exe
20:09:41 Response: 150 Ok to send data.
20:09:42 Response: 226 File receive OK.
20:09:42 Status: File transfer successful

Thanx!! :D

comment:4 Changed 11 years ago by Tim Kosse

Resolution: rejected
Status: newclosed

This is by design. The transfer connections get closed automatically to conserve resources. I'll slightly increase the idle disconnect time in the next version.

Note: See TracTickets for help on using tickets.