Opened 11 years ago

Closed 11 years ago

#3751 closed Bug report (rejected)

Queue sorting differences between recursive and direct downloads

Reported by: jwoelper Owned by:
Priority: normal Component: FileZilla Client
Keywords: queue sorting directory inverse Cc:
Component version: Operating system type: Windows
Operating system version: xp

Description

Please do not misunderstand: this is not a repeated "inverse queue" bug; rather an inconsistency wich (at least for me and many people i know) almost everytime creates time-consuming work of priority rescheduling:
If I manually create a local directory and download the _contents_ of a remote directory into it, they are perfectly in alphabetical order in the queue. If I directly download the remote folder, the contained files are being downloaded in inverse order compared to the above method. This is particularily neccesary for sequentially numbered image strips, sounds, etc.

Change History (1)

comment:1 Changed 11 years ago by Tim Kosse

Resolution: rejected
Status: newclosed

FileZilla never made any guarantees on queue sorting order. On recursive transfers, FileZilla adds the items to the queue in the same order as returned by the server for performance reasons. This is by design.

Note: See TracTickets for help on using tickets.