Opened 11 years ago

Last modified 6 years ago

#3547 closed Bug report

Reinstall of FileZilla client 3.0.11 uninstalls

Reported by: j_russell Owned by:
Priority: normal Component: Other
Keywords: Cc: j_russell, Tim Kosse
Component version: Operating system type:
Operating system version:

Description

Despite selecting Add/Remove/Reinstall components on a reinstall of FileZilla 3.0.11 and despite the final window reporting that "FileZilla Client 3.0.11 has been installed on your computer, the end result is that C:|Program Files\FileZilla FTP Client has been removed but the Registry entry @Uninstall\Filezilla Client and the start menu item are still there.

I couldn't catch a screen print of it, but the progress window does show "Uninstalling" as it scrolls.

Attachments (2)

07 Reinstall.7.0.jpg (21.8 KB) - added by j_russell 11 years ago.
screen print install steps
04 Reinstall.4.0.jpg (27.2 KB) - added by j_russell 11 years ago.

Download all attachments as: .zip

Change History (10)

Changed 11 years ago by j_russell

Attachment: 07 Reinstall.7.0.jpg added

screen print install steps

comment:1 Changed 11 years ago by Tim Kosse

That the previous version gets removed first is intended. The installer should have continued though afterwards.

What's your operating system?

comment:2 Changed 11 years ago by j_russell

Hi,

Thanks for the prompt response.

Note that this isn't an upgrade from previous version, it's just a re-install of 3.0.11 on top of 3.0.11 (but maybe that's what you meant by "previous version"). This is a system that did not previously have FileZilla installed. 3.0.11 was installed, then uninstalled. Then installed, then the installer was run again, Add/Remove/Reinstall is selected and at the end, the registry items and startup menu item remain, but the folder in Program Files was gone. I repeated the process a few times (uninstall, install, install again) and the same thing happened. The OS is Vista Home, SP1.

Today I tried it on an XP box that had an earlier version of FileZilla - the install upgraded and the reinstall reinstalled ok several times (with uninstalls in between), then I tried a cancel on an install (just at the second setting options window). Then installed an let it complete. Then reinstalled. After the reinstall the files were gone.

Thought about it. It's likely there was a cancel of the install somewhere along the line with the first PC sometime before the reinstalls started misbehaving.

Tried it on the same Vista home pc again today - without ever cancelling. Works fine everytime.

Tried it on another PC running Vista Enterprise. First round (install, reinstall) went ok but after I hit cancel on one of the steps the next time I installed it got confused on a subsequent reinstall and left out the install step. Was able to get this to happen twice in a row (1 reinstall puts the files back, the next takes em out) which I saw happen yesterday on the Vista Home pc. Everytime I'm selecting the default Add/Remove/Reinstall option on the reinstall.

So I can't quite claim that it happens without fail, but I have now seen it multiple times on the 2 different Vista PCs and alsoe on an XP. Cancelling an earlier install seems to be key to triggering the odd behavior. I hope this is enough for you to go on.

comment:3 Changed 11 years ago by Tim Kosse

Did you decline any UAC prompt?

comment:4 Changed 11 years ago by j_russell

No - haven't seen a UAC prompt on the times that it works and the times that it doesn't. And definitely didn't see a UAC prompt on the XP box, which also has the issue. :-)

comment:5 Changed 11 years ago by Tim Kosse

Check the components page if you (re-)install FileZilla, are by chance all components deselected?

Changed 11 years ago by j_russell

Attachment: 04 Reinstall.4.0.jpg added

comment:6 Changed 11 years ago by j_russell

Sorry - lied about the UAC prompt - yes it does come up on the start of the installer on the Vista machines.

As to whether components are selected, I've attached a screenprint from one of the reinstalls that resulted in no files but both the registry items and the start menu shortcut were still there. In my experience the top 3 components are always selected by default and I don't change that.
File Added: 04 Reinstall.4.0.jpg

comment:7 Changed 11 years ago by Tim Kosse

Please try to reproduce the problem with the upcoming 2008-06-21 build from http://filezilla-project.org/nightly.php

comment:8 Changed 11 years ago by j_russell

Hi,

I tried uninstalling and then the install and reinstall sequence a few times with the nightly build and have not got the problem to occur. As I'm not quite sure of the sequence that caused it (seemed to follow a cancelled install) I'm not sure if the problem is gone or I just haven't hit the right sequence. Unfortunately I do have other things I should be doing. Will let you know if I run into it again. Thanks.

Note: See TracTickets for help on using tickets.