Opened 11 years ago

Last modified 11 years ago

#3527 closed Bug report

Keep Alive not working

Reported by: stuart_bruges Owned by:
Priority: normal Component: Other
Keywords: Cc: stuart_bruges, Tim Kosse
Component version: Operating system type:
Operating system version:

Description

Connection drops after 45 seconds inspite of "keep alive" selected:

Status: Directory listing successful
Status: Sending keep-alive command
Command: NOOP
Response: 200 NOOP command successful
Response: 421 No Transfer Timeout (45 seconds): closing control connection.
Error: Disconnected from server

Using:
Version: FileZilla_3.0.10_win32-setup.exe
Op System: Using windows XP pro SP2

This is quite annoying.

Change History (3)

comment:1 Changed 11 years ago by Tim Kosse

The No Transfer Timeouts are entirely controlled by the server.

You need to contact the server administrator and demand that he sets sane timeouts. Something in the range of several hours to days should work fine for the timeouts.

comment:2 Changed 11 years ago by stuart_bruges

Professional FTP clients do not suffer this problem.
Do you know what the current period is between activity when the "keep alive" option is selected?
If you were able to reduce it to something like 28 seconds I would stay sane.

comment:3 Changed 11 years ago by stuart_bruges

Professional FTP clients do not suffer this problem.
Do you know what the current period is between activity when the "keep alive" option is selected?
If you were able to reduce it to something like 28 seconds I would stay sane.

Note: See TracTickets for help on using tickets.