Opened 11 years ago

Closed 10 years ago

Last modified 6 years ago

#3511 closed Bug report (rejected)

can't handle long file names

Reported by: jhartmann72 Owned by:
Priority: low Component: FileZilla Client
Keywords: long file name Cc: jhartmann72, Tim Kosse
Component version: Operating system type: Windows
Operating system version: Windows XP SP3

Description

When dragging files with long file names (or folders containing them) in 3.0.10 from a ProFTPD host to a Vista client, they are added to the cue, but not copied. (No error note is shown.) It's a problem solely in FileZilla, Vista itself can handle those file names without problems. So the workaround is, if one knows about this bug: rename the files to shorter file names, copy them, rename them back. Outside of FileZilla, because it cannot even rename them back on the Vista client.

Change History (7)

comment:1 Changed 11 years ago by Tim Kosse

Define "long"

comment:2 Changed 11 years ago by sf-robot

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

comment:3 Changed 10 years ago by Ramazan YAGMUR

Keywords: long file name added
Operating system type: Windows
Operating system version: Windows XP SP3
Priority: normalhigh
Status: closedreopened

Filezilla 3.2.4.1
client : Windows XP Pro SP3
server : Sun Solaris , fzSftp
mode : SFTP

long named files comes empty, renaming workaround does the trick but still uncomfortable.

comment:4 Changed 10 years ago by Tim Kosse

Status: reopenedmoreinfo_reopened

Since I don't like to repeat myself, read my previous reply to this ticket. Is it so hard to provide the requested information? Does it hurt?

comment:5 Changed 10 years ago by Ramazan YAGMUR

Status: moreinfo_reopenedreopened

as our explanations was not enough, your request completely non-understandable before your aggressive comment. define "long" , sounds like a variable definition must be long integer and was confusing :)

Anyway
I found out it is not about longname but used characters , if my file name includes ":" then file transfer seems to be done , but transferred file comes empty and with incomplete name.
While ":" allowed on server , it is not allowed on client so transfer fail. Other clients doesnt have this problem , they must be renaming on the fly if destination filesystem doesnt allow it.

comment:6 Changed 10 years ago by Ramazan YAGMUR

Priority: highlow

comment:7 Changed 10 years ago by Tim Kosse

Resolution: rejected
Status: reopenedclosed

Duplicate of #3227

Note: See TracTickets for help on using tickets.