Opened 11 years ago

Last modified 9 years ago

#3504 closed Bug report

mac ver issues

Reported by: spaceman37 Owned by: Alexander Schuch
Priority: normal Component: Other
Keywords: Cc: spaceman37, Alexander Schuch, Tim Kosse
Component version: Operating system type:
Operating system version:

Description

installed new ver on a mac.

i originally downloaded the ppc ver, cause i own both, on the mac mini intel, it crashed a lot.
so i downloaded the intel ver. turns out was a different problem, more details below. but switching may have caused issue 1.

(1)
main problem that is going to force me to find a different client to use.
can not save settings anymore.

it comes up with the settings that i had put in it before, but i try to save them is says cant find the file.
at one point i had moved the program also.
was going to run it from a usb drive/device.

is unclear to me witch part started the issue, due to can not get it working again to test.

i am able to save sites, in the site manager. is the preferances that wont save.

(2)
crashing,
appears is a permissions issue confected to an EX machine where the files are local network.

drag and drop to ftp window crashes most times. when drag to a sub dir on the server.
if i open the dir and click it, it works.

and crashes every time if their is a file usage permissions issue.
seems to only happen when i use winzip to zip the files.

Change History (11)

comment:1 Changed 11 years ago by Alexander Schuch

Which version of FileZilla are you using?

Which file cannot be found by FileZilla when you try to save the settings? At least on Unix, it stores the configuration files inside the user's home directory. No idea about MacOS X, though.

The Site Manager uses a different file than it is used for the settings. Maybe you have some kind of file/directory permission issue? Can you check this?

What do you mean by EX machine? Can you run FileZilla inside a debugger and provide a backtrace?

How does WinZip come into play?

comment:2 Changed 11 years ago by spaceman37

current ver.

EX was supose to be XP, wincrap.

i re-read 3 times. if you dont understand, then i dont know what to say.

what file?
the one it is trying to save, filezilla does not say. the preferences file.

so you are saying that if their is a permissions issue it cant find the file to save it?

you dont know mac?
who does?

well due to this, i actually reformated hard drive and reinstall factory/OS settings.
i use for work to connect to servers, dont realy have time to putz with it anymore, spent many hours as it is.

so debuging it is out of the question.

comment:3 Changed 11 years ago by spaceman37

wanted to add,

i remote into an XP machine i have here on the network.
used winzip to zip files.
try to upload via mac machine and local network connection.
it says it cant due to permissions.

then i can never upload to server till i change the name.
it keeps telling me the file exists on the server, and asks to overwrite ect....
but never works, get stuck in a loop trying to over write a file that does not exist on the server, maybe in the cashe, no clue.

comment:4 Changed 11 years ago by Alexander Schuch

1) FileZilla on MacOS X stores its configuration files (settings) in "~/.filezilla", that is, a directory called ".filezilla" in your user home directory. You should make sure that directory exists and FileZilla can properly write to it and modify/create any files in there. Does everything look alright there?

2) About the ZIP files... there is nothing special with these files from a FileZilla point of view. Maybe the FTP server you are using doesn't allow to create files with the extension ".zip", or something else, enforced by server configuration rules.

In your last statement you said that uploading ZIP files makes FileZilla retry over and over, but in your initial post, you said that FileZilla then crashes. What's correct?

The FileZilla crash when using drag'n'drop as described still needs to be investigated further. Looks like a real bug to me.

comment:5 Changed 11 years ago by spaceman37

the crashing was concerning the drag and drop, to a subdir on the server.

crashed drag multiple files from finder, *used to drag and drop files from explorer in win*

i actually don't rember exact details this part.

<
i usually figure what does work, and do that way from that moment on, so i have not tried it recently.

servers are using filezilla server, used for years with great results.
3 x win 2003 server standard, 0.9.23 beta.
win2k server, 0.9.23 beta
win 2003 server web edition, 9.23 beta

the permissions issue.
use winzip via RDP to zip files.
connect via mac OS X 10.5, filezilla 3.0.9.3 to zipped files on an XP macnine..
it starts the transfer, and says is a file error and stops. *crashed if to a subdir on server *
then no mater what i do, *be sure to exit winzip TSR*
it wont upload the file, i set filezilla to overwrite, or contiue,

endless loop saying the file exists and cannot overwrite it. *if is set to auto*
can not find it on the server. in filezilla, or via RDP.
only way was to rename the local file and upload.

comment:6 Changed 11 years ago by Tim Kosse

The crashes on drag and drop are a known issue. The crash reports indicate that this might be a problem deep inside OS X code. Furthermore, it does not happen on my machine. So unless somebody gives me full access to an affected machine for a couple of days, I cannot investigate this further.

comment:7 Changed 11 years ago by Alexander Schuch

"it starts the transfer, and says is a file error and stops. *crashed if to a subdir on server *" -- Does this mean that FileZilla crashes when trying to upload the ZIP file? This is a little confusing as you later write that FileZilla keeps asking you in an endless loop if you want to overwrite the file or not.

comment:8 Changed 11 years ago by spaceman37

well i just tryed the drag and drop from finder and filezilla.

multiple files into a sub dir and worked fine.

must be the ppc ver .

i had originally downloaded it cause have several ppc machines,
have not used it much on the other machines, but this intel i use it.

after format and reinstall OSX, it seems to work fine.
so the crashing may have been due to me installing the wrong ver.

i diod not realise i would need to remove the ppc ver, i moved it and put the intel ver where it was.
it did not like it.

i gues i should re-test the permissions issue also.

comment:9 Changed 11 years ago by spaceman37

connect XP via RDP.
explorer, right click winzip make zip file.
*was no TSR*

works if i use the XP build in make zip in explorer

####

popup window,
error 13, permission denied.

filezilla log. access via network to shared
Error: Failed to open "/Volumes/WebSites/updates/2008-05-20.zip" for reading

####

closed explorer and still no permissions to retry and test the looping issue.
try to open in finder and still no permission.
so the permissions is not the filezilla issue.

problem is when the permissions once released , would try to upload it, and thats when it got stuck.
kept saying the file existed, but i could not find it.
tell it to overwrite, resume, nothing worked exept renaming the local one.

but even after i rebooted the XP machine i am unalbe to get permission.

so i can not test the looping/file exists till i rember how or what i did.
hmm, i copy the file to a different dir, and copy it back, released the permissions and it uploaded.

all maybe my fault, ilike i say, i had originally download the ppc ver on a g4, when i got an intel, i copyed it from that machine.
when all the crashing started i went to the site and saw the intel ver.
it seem to have issues with the original ppc files.
since at the time of the posting, the guy did not know where these files lived, i reinstalled the OS.
and downloaded the intel ver.

that works as intended.

i dont rember, was trying so many programs for my new mac, but i was under the impresion at the time, *could be wrong* that the ppc ver worked on intel also.

anyway, great program, use for years on PC.
many thx.

comment:10 Changed 11 years ago by Alexander Schuch

So everything works now?

comment:11 Changed 11 years ago by sf-robot

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

Note: See TracTickets for help on using tickets.