Opened 16 years ago

Last modified 6 years ago

#332 closed Bug report

Cannot cd into subdir if dir is a .lnk

Reported by: mbabuskov Owned by:
Priority: normal Component: Other
Keywords: Cc: mbabuskov, nilsoncain, Tim Kosse
Component version: Operating system type:
Operating system version:

Description

The problem is with filezilla server.

I don't know how to access files on different partitions
(I tried
cd d:

but it didn't work)

So I created .lnk file in my C: root, that points to my
D: disk.

I can do
cd DiskD.lnk

from ftp client, but I cannot cd into any subdir...

I hangs for some time, and then it outputs that
directory isn't found.

Change History (6)

comment:1 Changed 16 years ago by nilsoncain

Have you tried adding the directory in the user's
access-rights dialog?

comment:2 Changed 16 years ago by mbabuskov

Yes I did, I forgot to write that. I gave rights to the
whole D: partition, and to that subdirectory, but it doesn't
work.

The server tries to do CWD to dir:
/DiskD.lnk/subdir

and then complains that it does'n exist. I see three
possible solutions to this:

  1. allow relative CWD's (this will require that servers

remembers last cwd of a client)

  1. check if any part of the path is shortcut (.lnk) and

translate that into real path:

  • check the part
  • if it is a shortcut: forget everything before and

translate that to the real path, example:

cd /ftp_files/diskd.lnk/some_dir/some_subdir

when the parsing reaches "diskd.lnk", it should translate
the command to:

cd d:/some_dir/some_subdir

and then start over.

  1. allow to change base_dir with command like:

cd c:
cd d:
etc.

and all the absolute paths will use that disk partition.

comment:3 Changed 16 years ago by Tim Kosse

If resolving .lnk files is enabled and the if the user has proper
permissions, .lnk files appear as regular folder in the directory
listing and can be accessed this way.
So if the file is myfolder.lnk, it can acessed by CWD myfolder
for example.

comment:4 Changed 16 years ago by mbabuskov

You didn't read my post.

I can also cd into myfolder.lnk directory, no problem.

But, I cannot cd into ANY SUBDIR in that myfolder directory.

comment:5 Changed 16 years ago by Tim Kosse

I think I do now understand your problem.
Please try the test release from
http://filezilla.sourceforge.net/FileZilla_Server.exe

comment:6 Changed 16 years ago by mbabuskov

Ok. Now it works for directories, but it still doesn't work
for partitions.

Assuming that you have 2 partitions (C: and D:), try this:

  1. Create .lnk to D: somewhere on C: disk
  2. Give rights to user to both C: and D: and all subdirs,

and setup C: to be home directory

  1. Login to server
  2. cd into .lnk that leads to D:

so far, so good, now:

  1. try to enter into any dir on D: disk...
Note: See TracTickets for help on using tickets.