Opened 12 years ago

Closed 3 years ago

#3267 closed Bug report (outdated)

3.5.3 Slow Startup

Reported by: sconeu Owned by:
Priority: normal Component: FileZilla Client
Keywords: startup delay Cc: sconeu, Tim Kosse
Component version: Operating system type: Windows
Operating system version: XP SP3

Description (last modified by Tim Kosse)

OS: WinXP SP 2
HW: Dell Dimension 5150, P4 3.2GHz, 1GB RAM

On my system, FileZilla Client 3.0.1 takes approximately 25 seconds to start. This time period is fairly constant whether or not the file is cached.

FileZilla 2.x had relatively short startup times.

Change History (25)

comment:1 Changed 12 years ago by Tim Kosse

Please try creating a new useraccount on your system, login with it and start FileZilla on that account.

comment:2 Changed 12 years ago by sf-robot

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

comment:3 Changed 11 years ago by rothkj1022

Status: closedreopened

I don't agree that this is fixed. I still experience this slow startup even on machines that I've just installed FileZilla on for the first time. Several members of my developer team still use 2.x because of this issue. Please reopen this issue.

comment:4 Changed 11 years ago by Tim Kosse

Status: reopenedmoreinfo_reopened

Ah, they are developers? Great! Then they are capable to debug FileZilla to fix this problem. Because I can not do it myself since I am not affected by this problem.

Please attach a patch that will fix this problem.

comment:5 in reply to:  4 Changed 11 years ago by rothkj1022

Operating system type: Windows
Operating system version: XP SP2
Status: moreinfo_reopenedreopened

If I could fix it myself I would, as I use FileZilla all the time. Unfortunately we're web developers, so we won't be much help. We do love the application and appreciate the free software but this is definitely still an issue, at least for us (all 7 of our team members have experienced this). We are all running XP SP2, FYI.

comment:6 in reply to:  4 Changed 11 years ago by zuckerle

Keywords: Slow Startup added
Operating system version: XP SP2XP SP3

Hi,

I also was affected by this behaviour of Filezilla.
In my case, it was releted to network drives, that were listed in the Explorer, but actually not connected/powered up.
After "disconnect network drive" of the above mentioned currently non-existing drives in the explorer, startup of Filezilla was normal.
Seems something is running into a timeout of about 30sec.

I am using WinXP/SP3

comment:7 Changed 11 years ago by rothkj1022

Confirmed! I after disconnecting all my network drives FileZilla opened immediately. I then re-added them and FileZilla still opened immediately. So it seems you need to at least have browsed to every one of your network drives prior to opening FileZilla in order to avoid the delay.

Seems like this could potentially be an easy fix now that the circumstances for reproducing the problem have been identified. Here's hoping.

comment:8 Changed 11 years ago by Tim Kosse

Resolution: wontfix
Status: reopenedclosed

Only Microsoft can fix this one.

comment:9 in reply to:  8 Changed 11 years ago by rothkj1022

Resolution: wontfix
Status: closedreopened

Replying to codesquid:

Only Microsoft can fix this one.

I highly doubt that, as there are plenty of other applications I run that read the file system, and the do not have this problem.

Sounds like you won't fix it, not can't fix it. It's a shame you don't feel like giving it a shot.

comment:10 Changed 11 years ago by rothkj1022

Also, 2.x didn't have this problem. Microsoft didn't have anything to do with that...

comment:11 Changed 11 years ago by Jesse Donat

I just tested 2.x vs. 3.x several times, 2.x loads in 3 seconds whereas 3.x took 10-12 seconds. Definetly a downgrade.

comment:12 in reply to:  4 Changed 11 years ago by zuckerle

What I see as problematic is:
There is asolutely no response from Filezille visible after starting the program.
My first reaction was to click start a second time .... and then I thought "what a shi..... software" ;-)

If there were a reaction, startup screen or anything visible, it would be better.
So in my eyes, independent of some incompatibility to M$ OS behaviour, there is a chance to improve usability and user acceptance by changing the programms startup sequence. First give some life signs and then rifle through the file system....
(or even better: do not rifle through the file system as long as there is no need to do it)

comment:13 Changed 10 years ago by Tim Kosse

Status: reopenedmoreinfo_reopened

Please try version 3.2.5

comment:14 Changed 10 years ago by bz

Operating system version: XP SP3XP SP2

I just started experiencing the same issue (30-40sec startup time).

Nothing in my hardware configuration changed, no new software installed and yesterday it was still running fine.

Upgraded to 3.2.5 to no effect.
Disabling firewall/AV didn't help either.

Only thing that helps is if i unplug/disable network connection.

comment:15 Changed 9 years ago by Jorrit Schippers

Removing disconnected network drives solved this problem for me.

comment:16 Changed 9 years ago by Gary Turner

Operating system version: XP SP2XP SP3

Running 3.3.5.1 on XP Home SP3. Just upgraded from 3.3.5 - and still slow.
Startup time can be up to 4 minutes, which is utterly ridiculous.
Closing and re-running soon after is pretty much immediate.
Since it's XP Home - I have no disconnected network drives to close. (Do network places work the same?)
If it IS a MS networking bug - might it be possible to add an option to not enumerate network drives, if that is what you do?

comment:17 Changed 7 years ago by Alexander Schuch

Does this problem still occur with FileZilla 3.5.3?

comment:18 in reply to:  17 Changed 7 years ago by zuckerle

Status: moreinfo_reopenedreopened

Just did a test with disconnected network cable.
Startup was immediate.
So, in this configuration, problem didn't appear with 3.5.3.

comment:19 Changed 7 years ago by Alexander Schuch

Resolution: fixed
Status: reopenedclosed

So I consider this bug as fixed. If you encounter it again, please feel free to reopen this bug report.

comment:20 Changed 7 years ago by Gary Turner

Resolution: fixed
Status: closedreopened
Summary: 3.0.1 Slow Startup3.5.3 Slow Startup

Certainly isn't fixed for me. Currently about a 5-10 minute wait after starting before the window appears.

comment:21 Changed 7 years ago by Gary Turner

Status: reopenedmoreinfo_reopened

Not sure if it is related to this - but i've just done a procmon trace of filezilla during the usual 10 minute startup delay. Filezilla seems to be reading my entire google maps cache. Is there some reason for this? And/or any way I can stop it?
Below are two of the repeated queries it appears to be doing...

13:05:03.5178680 filezilla.exe 5536 ReadFile C:\$Directory SUCCESS Offset: 102,629,376, Length: 4,096, I/O Flags: Non-cached, Paging I/O, Synchronous Paging I/O
13:05:03.5593630 filezilla.exe 5536 QueryDirectory C:\GoogleMaps SUCCESS 0: srsrrqsqrsqttrstq.jpg, 1: srsrrqsqrsqttrstr.jpg, 2: srsrrqsqrsqttrsts.jpg, 3: srsrrqsqrsqttrstt.jpg, 4: srsrrqsqrsqttrt.jpg, 5: srsrrqsqrsqttrtrq.jpg, 6: srsrrqsqrsqttrtrr.jpg, 7: srsrrqsqrsqttrtrs.jpg, 8: srsrrqsqrsqttrtrt.jpg, 9: srsrrqsqrsqttrtsq.jpg, 10: srsrrqsqrsqttrtsr.jpg, 11: srsrrqsqrsqttrtss.jpg, 12: srsrrqsqrsqttrtst.jpg, 13: srsrrqsqrsqtts.jpg, 14: srsrrqsqrsqttsqs.jpg, 15: srsrrqsqrsqttsqssr.jpg, 16: srsrrqsqrsqttsqsss.jpg, 17: srsrrqsqrsqttsrs.jpg, 18: srsrrqsqrsqttsrstq.jpg, 19: srsrrqsqrsqttsrstt.jpg, 20: srsrrqsqrsqttsrt.jpg, 21: srsrrqsqrsqttsrtsq.jpg, 22: srsrrqsqrsqttsrtsr.jpg, 23: srsrrqsqrsqttsrtss.jpg, 24: srsrrqsqrsqttsrtst.jpg, 25: srsrrqsqrsqttsrtt.jpg, 26: srsrrqsqrsqttsrttq.jpg, 27: srsrrqsqrsqttsrttr.jpg, 28: srsrrqsqrsqttsrtts.jpg

comment:22 Changed 7 years ago by Alexander Schuch

Status: moreinfo_reopenedreopened

comment:23 Changed 7 years ago by Alexander Schuch

Keywords: startup delay added; Slow Startup removed

comment:24 Changed 7 years ago by Ronald Lammers

Bug is not (fully) Windows related.

I run Filezilla 3.6.0.2 on Linux Mint 14 and get slow start up times (abt 30 secs) with samba-drives mounted.

The slow start disappears when the NAS-drives are unmounted. Opening the drives in the filebrowser before starting filezilla does not help.

I also use filezilla on windows-systems (vista and 7) with the same NAS-drives. On those systems start up is normal: no delay.

comment:25 Changed 3 years ago by Tim Kosse

Description: modified (diff)
Resolution: outdated
Status: reopenedclosed
Note: See TracTickets for help on using tickets.