Opened 16 years ago

Last modified 9 years ago

#323 closed Bug report

Non-English character compatability

Reported by: booboobird Owned by:
Priority: normal Component: Other
Keywords: Cc: booboobird, Tim Kosse
Component version: Operating system type:
Operating system version:

Description

Some non-English charaters (ex. Chinese characters)
have problem with FileZilla, while these characters are
OK on UNIX systems. When I made directories with
FileZilla "Create directory" command, there was no
error messages about making directories, but names of
those directories did not display correctly in
FileZilla remote directory window (display with spaces)
and consequently "cd" to those directories was not
possible.

I found that the character with hexidemical code "B57B"
is incompatable with FileZilla. (Remember that Chinese
characters have a double-byte character system.) I
suspect that the first byte "B5" is responsible for
this issue.

I tried CuteFTP (4.0 and PRO) with it, both versions
didn't display correct directory name but "cd" command
was OK and upload/download worked well.

The local directory window of FileZilla doesn't suffer
from this problem however.

Change History (1)

comment:1 Changed 14 years ago by Tim Kosse

This bug report has been closed due to inactivity and has possibly
already been solved.

You can reopen this report if the issue still exists in the
latest version of FileZilla (Server).

Note: See TracTickets for help on using tickets.