Opened 12 years ago

Last modified 5 years ago

#3139 closed Bug report

PASV and Active Fails-Client on DSL/PPPoE

Reported by: foxtail22 Owned by:
Priority: normal Component: Other
Keywords: Cc: foxtail22, Tim Kosse
Component version: Operating system type:
Operating system version:

Description

Sorry, I put this on the FZ 2x list by mistake. Am reposting on FZ3.0 list.

I am not sure exactly what is happening but I an a friend of my are having
the following issue:

Configuration Info

We both have:

  • FileZilla 3.0 b7 installed
  • DLink DNS323 500GB RAID1 servers(Unix L8)on our respective networks

configured for FTP

  • NATed networks behind Linksys Routers with MTU=1492
  • Running Windows XP clients
  • Have ports 21, 5000-5100(preferred by prior version of FileZilla, and

65500-65535(preferred by DNS 323 in PASV) forwarded on the routers

  • Set FileZilla b7 to use Servers External IP
  • We both are using DNS name server via DynDNS.org because our ISPs change

our IPs several times a week.

Whats Different

  • My access is 250/3000 Cable with Auto IP
  • His access is 600/6000 DSL using PPPoE
  • My client PC uses Norton Virus and Firewall SW
  • His client PC uses ATT protection for Yahoo SW
  • Note: We have tried disabling firewalls and Internet Secuity Setting with

no affect on results

Issue Outlined

  • My client from my network has no issues connecting with and transferring

files to and from his server either in Active or Passive Mode when using
3.0 b7 over his DSL/PPPoE based service.

  • His FZ2.31 client logs on to my server from his network in Active Mode

without issues. Passive does not work because it needs servers external IP
to work.

  • His FZ 3.0b7 client fails both Active and Passive connections to my

server when he tries from his network. However,when he tried from his
son's cable serviced network, he was able to log on and tranfer files both
in Active and Passive Mode.

I am current thinking that the issue is somehow related to his PPPoE
connection but why does FZ 2.31 work in Active Mode while FZ 3.0b7 fails to
connect in either mode when he tries to connect to my server from his
network. The trace shows that the socket closes as soon as the PASV
command is issued and the disconnect then follows.

I have included the trace for Passive Mode. I do not yet have a trace for
the Active Mode. I have asked my friend for it and I will add it when I
get it.

Status:Resolving IP-Address for SERVER.gotdns.com
Trace:ControlSocket.cpp(167): CControlSocket::ContinueConnect(011EBA10)
m_pEngine=011FF008 caller=012100A8
Status:Connecting to (Servers ext IP):21...
Status:Connection established, waiting for welcome message...
Trace:CFtpControlSocket::OnReceive()
Response:220 NAS-500GB FTP server (Version wu-2.6.2(52) Tue Jan 2 14:13:26
EST 2007) ready.
Command:USER Bill
Trace:CFtpControlSocket::OnReceive()
Response:331 Password required for Bill.
Command:PASS
Trace:CFtpControlSocket::OnReceive()
Response:230-Welcome to my FTP site.
Trace:CFtpControlSocket::OnReceive()
Response:230-Now is the time ==> Sun Apr 8 13:27:41 2007
Response: 230-The host name is NAS-500GB
Response: 230-You are Bill
Response: 230-There are 1 person in my site, now.
Response: 230-
Response: 230-
Response: 230 User Bill logged in.
Command: SYST
Trace: CFtpControlSocket::OnReceive()
Response: 215 UNIX Type: L8
Command: FEAT
Trace: CFtpControlSocket::OnReceive()
Response: 500 'FEAT': command not understood.
Status: Connected
Trace: CFtpControlSocket::ResetOperation(0)
Trace: CControlSocket::ResetOperation(0)
Status: Retrieving directory listing...
Trace: CFtpControlSocket::SendNextCommand(0)
Command: PWD
Trace: CFtpControlSocket::OnReceive()
Response: 257 "/" is current directory.
Trace: CFtpControlSocket::ResetOperation(0)
Trace: CControlSocket::ResetOperation(0)
Trace: CFtpControlSocket::SendNextCommand(0)
Trace: CFtpControlSocket::ListSend(0)
Trace: state = 1
Trace: CFtpControlSocket::SendNextCommand(0)
Trace: CFtpControlSocket::TransferSend(0)
Trace: state = 1
Command: TYPE I
Trace: CFtpControlSocket::OnReceive()
Response: 200 Type set to I.
Trace: CFtpControlSocket::TransferParseResponse()
Trace: code = 2
Trace: state = 1
Trace: CFtpControlSocket::TransferSend(0)
Trace: state = 2
Command: PASV
Trace: CControlSocket::OnClose()
Error: Disconnected from server
Trace: CFtpControlSocket::ResetOperation(66)
Trace: CControlSocket::ResetOperation(66)
Trace: CFtpControlSocket::ResetOperation(66)
Trace: CControlSocket::ResetOperation(66)
Error: Failed to retrieve directory listing

Change History (1)

comment:1 Changed 12 years ago by foxtail22

Active Mode issue was caused by router Mac address clone being set. 2.31 runs for him in active mode with either Mac turned on or off but FZ3 needs it turned off for active mode to work.

Still have not figured out why socket goes to onClose immediately after PASV command is sent. Seems like a short timeout occurs and looks like PASV command is getting blocked by something releated to PPPoE setup because same setting on non-PPPoE based service work fine in either Active or Passive mode.

Note: See TracTickets for help on using tickets.