Opened 13 years ago

Last modified 13 years ago

#3069 closed Bug report

Auto update doesn't shutdown running app

Reported by: mrsmiley18 Owned by: Tim Kosse
Priority: normal Component: Other
Keywords: Cc: mrsmiley18, Tim Kosse, Alexander Schuch
Component version: Operating system type:
Operating system version:

Description

Currently running on Windows XP Pro SP2, FileZilla
3.0.0-beta2

I was running the beta1 version and it told me the
beta2 release was out. After following the prompts,
it auto downloaded beta2, but left the current
FileZilla instance running while it tried to install
beta2. This causes a file is in use error. The way
around it was for me to manually shutdown the running
instance, and then continue where the install worked
fine after that.

I would have expected the installer to close the
running instance, install the new version, then open
the new version to avoid the file system errors.

Change History (3)

comment:1 Changed 13 years ago by Alexander Schuch

What do you mean by "it tried to install beta2"? After the
beta2-archive was downloaded, it automatically tried to
uncompress the archive?

comment:2 Changed 13 years ago by Tim Kosse

Under Windows, the setup program is run automatically after
downloading the updated version.

comment:3 Changed 13 years ago by Tim Kosse

Thanks for reporting. This issue has been fixed in the CVS
repository and will be available with the next version.

Note: See TracTickets for help on using tickets.