Opened 17 years ago

Last modified 17 years ago

#303 closed Bug report

Getting directory listing on SSL EXplicit sites fails

Reported by: mrflibble Owned by:
Priority: normal Component: Other
Keywords: Cc: mrflibble, Tim Kosse
Component version: Operating system type:
Operating system version:

Description

When logging in to an SSL EXplicit-enabled site, after
the LIST command has been sent, nothing happens, then
the client times out.

This happened on Filezilla 2.1.5 when trying to connect
to ProFTPD 1.2.8 and 1.2.8rc2 servers.
The server certificate is accepted, but then no
directory listing appears. The client times out, but
the server connection stays open (until the server
times it out).

Other clients (smartftp, ws_ftp, and the client from
bsdftpd-ssl.sc.ru) work fine.

thanks,

Change History (6)

comment:1 Changed 17 years ago by Tim Kosse

Please try the latest test release from
http://filezilla.sourceforge.net/FzSetup.exe, the SSL code has
been improved in this version.

comment:2 Changed 17 years ago by mrflibble

i'm afraid the same thing happens.

would you like a login and password for testing?

comment:3 Changed 17 years ago by Tim Kosse

A test account would be great. Please send the account
details per mail to tim.kosse@…

comment:4 Changed 17 years ago by Tim Kosse

Please upgrade to FileZilla 2.1.6. You may also have to
toggle "Passive mode" on the firewall page in the settings
dialog.

comment:5 Changed 17 years ago by mrflibble

hi there. we've just tried 2.1.7 and we still get the same
problem.
did you manage to log on successfully to our server?

comment:6 Changed 17 years ago by Tim Kosse

With 2.1.7, I've no problems connecting to your server, both
passive and active mode works fine.

Note: See TracTickets for help on using tickets.