Opened 14 years ago

Last modified 5 years ago

#3020 closed Bug report

default remote path not definable for Netware ftp server

Reported by: elac Owned by:
Priority: normal Component: Other
Keywords: Cc: elac, jtvdr, Alexander Schuch, Tim Kosse
Component version: Operating system type:
Operating system version:

Description

accessing a netware ftp server there must be ppossible
to define a remote path (under the Advance section)
which looks like:


netwareserver\volume\path1\path1

where netwareserver is the servername, volume is the
volume of the netwareserver, followed by the directory
The path must begin with 2 backshlash like I#ve pointed
out above.

If I enter this path, FileZilla (V 2.2.13c) is
converting it to

/netwareserver/volume/path1/path1/

Change History (6)

comment:1 Changed 14 years ago by jtvdr

There is a work-around for this:

Under the File transfer settings I unchecked the "use
multiple connections to transfer files" box, and now I can
login, get placed in server1\homedir, do the raw FTP command
CWD
server2\othervol, navigate down into those directories
on
server2\othervol and transfer files and directories.

I don't know why this change would make it work, but it does.

some more info from one of my users:
After doing the CWD, I had to "refresh views" to get the
directory listing. The folder tree didn't refresh correctly,
though. If I type "/othervol/" (=server2\othervol) into the
folder bar, it will show the correct folder list, but shows
the homedir (server1\homedir) volume at the same level as
the othervol (server2\homedir) volume. Clicking on the
homedir volume fails to change the directory (I have to do
another manual CWD to get back).

This fix also disables one of the nicer features of
FileZilla. When doing file transfers, the program opens a
second connection to the server and uses that to do the
transfers. If there are a lot of files to transfer, it's
possible to dump them in the queue and have it chug away in
the background. The advantage is that it's still possible to
navigate and work in the primary connection while the
transfers are happening.

HTH fix the core issue, while preserving the background
transfer feature.

comment:2 Changed 11 years ago by Alexander Schuch

Can you please try the latest version of FileZilla 3? Maybe it works using FTP protocol there. Does it?

However, there is already a related bug report which has this issue using SFTP access:
[ 1579575 ] SFTP cannot cd to host/share

comment:3 Changed 11 years ago by Alexander Schuch

I right now tried to enter "
something\test\" as default remote directory, and FileZilla 3 didn't accept it. So looks like this is still not possible in FileZilla 3.

comment:4 Changed 11 years ago by Alexander Schuch

This also looks a bit like the following report:
[ 1964794 ] Display issues on win server using \ rather than /

comment:5 Changed 11 years ago by Tim Kosse

I can only add this servertype if the following condition holds:

If you enter "CWD
something\foo\bar" and it succeeds, and then do PWD, it has to reply again with "
something\foo\bar".

If the server part is missing, I cannot add this format. Both "
A\foo" and "
B\foo" would map to "\foo". If FileZilla sees "\foo", it has no idea if it is in "
A\foo" or in "
B\foo".

Is your filesystem sane (PWD contains the server) or not (PWD does not contain the server)?

comment:6 Changed 11 years ago by sf-robot

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

Note: See TracTickets for help on using tickets.