Opened 14 years ago

Closed 9 years ago

Last modified 5 years ago

#2463 closed Feature request (rejected)

Make UTF8 support selectable

Reported by: fakejack Owned by:
Priority: normal Component: FileZilla Server
Keywords: Cc: fakejack, Tim Kosse
Component version: Operating system type:
Operating system version:

Description

Hi,

It would be nice if UTF8 file naming support would
not be 'wired' into FileZilla Server. I think, many
people use such ftp-clients that do not yet support
the UTF8 character set. So it would be nice if you
could implement a checkbox that makes UTF8 support
only a selectable feature (and the default setting
would be the 'old' character set like in 0_9_14a and
earlier versions).

Regards,
FJ

Change History (5)

comment:1 Changed 14 years ago by Tim Kosse

UTF-8 has to be forced. Only standard conformant encodings
are 7bit US-Ascii (no foreign characters) or UTF-8.

comment:2 Changed 9 years ago by Andys

Status: closedreopened

Please reconsider this feature (and it would not need any real effort to implement since I tested OPTS UTF8 OFF command in non-unicode ftp client and it worked just as intended - folders with non-english letters were browsable and files were downloadable).

With UTF8 OFF I can browse ftp directories and download files just fine as long as client's codepage is the same as server's. Local symbols >127 work ok.
Forcing this option ON means that no one would ever be able to browse non-english paths with standard web browsers (which in majority do not support this option).

The world where everyone uses ftp clients is only a wishful dream, in real world there are always people that just can't understand anything more complex than IE.

comment:3 Changed 9 years ago by Tim Kosse

Resolution: rejected
Status: reopenedclosed

If not using UTF-8, the only other standards compliant encoding is ASCII. Since ASCII is a subset of UTF-8, there is no point in making UTF-8 optional.

Forcing this option ON means that no one would ever be able to browse non-english paths with standard web browsers (which in majority do not support this option).

In other words, your browser is broken. Contact your browser manufacturer so that he can fix his browser.

comment:4 Changed 9 years ago by Andys

In other words, when using your server for public sharing I would have to either answer my users with 'go google it, dumbhead' or waste half a hour explaining ftp client usage.

comment:5 Changed 9 years ago by Andys

Problem solved, thanks for providing server sources :)

Note: See TracTickets for help on using tickets.