Opened 14 years ago

Closed 2 years ago

#2456 closed Feature request (rejected)

Allow RNTO to overwrite an existing file

Reported by: kat888 Owned by:
Priority: normal Component: FileZilla Server
Keywords: Cc: kat888
Component version: Operating system type:
Operating system version:

Description

It would be nice if FileZilla server had an option for
ignore errors when the RNTO command points to an
existing file. I mean that if a client sends a RNFR
<filename1> and a RNTO <filename2>, the server now
sends always an error if a file named <filename2>
already exists. I'd like to choose the behaviour in
order to avoid this.
regards

Change History (4)

comment:1 by Jori Seidel, 9 years ago

I know this entry is over 5 years old, but I have a situation which is similar to this forum post: http://forum.filezilla-project.org/viewtopic.php?f=3&t=1075&start=0&st=0&sk=t&sd=a . Can this option still be made available?

comment:2 by Kurt McKee, 3 years ago

I can confirm that FileZilla Server 0.9.60 will prevent a file from being overwritten during a rename operation.

It appears that RFC 959 defines the RNFR and RNTO commands. RFC 959 does not seem to state that renames must fail if the destination file already exists. That is, it may be acceptable behavior to allow an existing file to be overwritten.

For other file-related commands that could have conflicts, RFC 959 appears to specify that the server must overwrite or append the data:

  • STORE (STOR): "If the file specified in the pathname exists at the server site, then its contents shall be replaced by the data being transferred."
  • APPEND (APPE): "If the file specified in the pathname exists at the server site, then the data shall be appended to that file"

This seems to set a precedent that would allow the RNFR/RNTO commands to overwrite an existing file.

Nevertheless, @codesquid may know of other RFC's or precedent, so I defer to his insight on the proposed behavioral change.

comment:3 by Kurt McKee, 3 years ago

Summary: RNTO overwrite option in serverAllow RNTO to overwrite an existing file

comment:4 by Kurt McKee, 2 years ago

Resolution: rejected
Status: newclosed

It appears that this isn't going to get implemented. I'm closing this ticket due to its age.

Note: See TracTickets for help on using tickets.