Opened 14 years ago

Closed 5 years ago

#2402 closed Feature request (worksforme)

VMS optional inclusion of version number

Reported by: jspi Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc: jspi, duboiss, Alexander Schuch
Component version: Operating system type:
Operating system version:

Description

There should be added some OpenVMS (or in general
server system) support. E.g. a file on OpenVMS X.TXT;5
should be copied to x.txt and not to x.txt;5 on
Windows. Only WS FTP supports this feature.

Change History (4)

comment:1 Changed 12 years ago by duboiss

I agree.

a) The version should disapear when downloaded on Windows, unless multiple versions downloaded at the same time. See example below.

b) The list view should sort the highest version first - or - show only the latest version (an option to show versions would be great).

Below is a sample at debug 3 level from Filezilla 3.0.0. The "ACME$SERVER.LOG;33" file was downloaded on Windows with the extention ".LOG;33" when ".LOG" would be better (On VMS, a version is not an extention).


Status: Resolving IP-Address for brom6
Trace: ControlSocket.cpp(948): CRealControlSocket::ContinueConnect(010257E0) m_pEngine=0104B980 caller=012A0C48
Status: Connecting to 134.199.145.179:21...
Status: Connection established, waiting for welcome message...
Trace: CFtpControlSocket::OnReceive()
Response: 220 brom6.bromont.dalsa.org FTP Server (Version 5.6) Ready.
Command: USER system
Trace: CFtpControlSocket::OnReceive()
Response: 331 Username system requires a Password
Command: PASS
Trace: CFtpControlSocket::OnReceive()
Response: 230 User logged in.
Command: SYST
Trace: CFtpControlSocket::OnReceive()
Response: 200 VMS OpenVMS V8.3 on node brom6.bromont.dalsa.org.
Command: FEAT
Trace: CFtpControlSocket::OnReceive()
Response: 502 FEAT is unimplemented.
Status: Connected
Trace: CFtpControlSocket::ResetOperation(0)
Trace: CControlSocket::ResetOperation(0)
Status: Retrieving directory listing...
Trace: CFtpControlSocket::SendNextCommand(0)
Command: PWD
Trace: CFtpControlSocket::OnReceive()
Response: 257 "SYS$SYSROOT:[SYSMGR]" is current directory.
Trace: CFtpControlSocket::ResetOperation(0)
Trace: CControlSocket::ResetOperation(0)
Trace: CFtpControlSocket::SendNextCommand(0)
Trace: CFtpControlSocket::ListSend(0)
Trace: CFtpControlSocket::SendNextCommand(0)
Trace: CFtpControlSocket::TransferSend(0)
Command: TYPE I
Trace: CFtpControlSocket::OnReceive()
Response: 200 TYPE set to IMAGE.
Trace: CFtpControlSocket::TransferParseResponse()
Trace: CFtpControlSocket::TransferSend(0)
Command: PASV
Trace: CFtpControlSocket::OnReceive()
Response: 227 Entering Passive Mode (134,199,145,179,244,240)
Trace: CFtpControlSocket::TransferParseResponse()
Trace: CFtpControlSocket::TransferSend(0)
Command: LIST
Trace: CTransferSocket::OnConnect
Trace: CFtpControlSocket::OnReceive()
Response: 150 Opening data connection for SYS$SYSROOT:[SYSMGR]*.*;* (134.199.147.14,2003)
Trace: CFtpControlSocket::TransferParseResponse()
Trace: CFtpControlSocket::TransferSend(0)
Trace: CTransferSocket::OnClose
Trace: CTransferSocket::TransferEnd(1)
Trace: CFtpControlSocket::OnReceive()
Response: 226 LIST Directory transfer complete.
Trace: CFtpControlSocket::TransferParseResponse()
Trace: CFtpControlSocket::TransferSend(0)
Trace: CFtpControlSocket::TransferEnd()
Trace: CFtpControlSocket::ResetOperation(0)
Trace: CControlSocket::ResetOperation(0)
Trace: CFtpControlSocket::SendNextCommand(0)
Trace: CFtpControlSocket::ListSend(0)
Trace: CFtpControlSocket::ResetOperation(0)
Trace: CControlSocket::ResetOperation(0)
Status: Directory listing successful
Status: Resolving IP-Address for brom6
Trace: ControlSocket.cpp(948): CRealControlSocket::ContinueConnect(012CE6D8) m_pEngine=01291F18 caller=012DCD98
Status: Connecting to 134.199.145.179:21...
Status: Connection established, waiting for welcome message...
Trace: CFtpControlSocket::OnReceive()
Response: 220 brom6.bromont.dalsa.org FTP Server (Version 5.6) Ready.
Command: USER system
Trace: CFtpControlSocket::OnReceive()
Response: 331 Username system requires a Password
Command: PASS
Trace: CFtpControlSocket::OnReceive()
Response: 230 User logged in.
Status: Connected
Trace: CFtpControlSocket::ResetOperation(0)
Trace: CControlSocket::ResetOperation(0)
Trace: CFtpControlSocket::FileTransfer()
Status: Starting download of SYS$SYSROOT:[SYSMGR]ACME$SERVER.LOG;33
Trace: CFtpControlSocket::SendNextCommand(0)
Command: CWD SYS$SYSROOT:[SYSMGR]
Trace: CFtpControlSocket::OnReceive()
Response: 250-CWD command successful.
Response: 250 New default directory is SYS$SYSROOT:[SYSMGR]
Command: PWD
Trace: CFtpControlSocket::OnReceive()
Response: 257 "SYS$SYSROOT:[SYSMGR]" is current directory.
Trace: CFtpControlSocket::ResetOperation(0)
Trace: CControlSocket::ResetOperation(0)
Trace: CFtpControlSocket::SendNextCommand(0)
Trace: FileTransferSend()
Trace: CFtpControlSocket::SendNextCommand(0)
Trace: CFtpControlSocket::TransferSend(0)
Command: TYPE I
Trace: CFtpControlSocket::OnReceive()
Response: 200 TYPE set to IMAGE.
Trace: CFtpControlSocket::TransferParseResponse()
Trace: CFtpControlSocket::TransferSend(0)
Command: PASV
Trace: CFtpControlSocket::OnReceive()
Response: 227 Entering Passive Mode (134,199,145,179,244,245)
Trace: CFtpControlSocket::TransferParseResponse()
Trace: CFtpControlSocket::TransferSend(0)
Command: RETR ACME$SERVER.LOG;33
Trace: CTransferSocket::OnConnect
Trace: CTransferSocket::OnClose
Trace: CTransferSocket::TransferEnd(1)
Trace: CFtpControlSocket::OnReceive()
Response: 150 Opening data connection for SYS$SYSROOT:[SYSMGR]ACME$SERVER.LOG;33 (134.199.147.14,2005) (60 bytes)
Trace: CFtpControlSocket::TransferParseResponse()
Trace: CFtpControlSocket::TransferSend(0)
Response: 226 Transfer complete.
Trace: CFtpControlSocket::TransferParseResponse()
Trace: CFtpControlSocket::TransferSend(0)
Trace: CFtpControlSocket::TransferEnd()
Trace: CFtpControlSocket::ResetOperation(0)
Trace: CTransferSocket::TransferEnd(1)
Trace: CControlSocket::ResetOperation(0)
Trace: CFtpControlSocket::SendNextCommand(0)
Trace: FileTransferSend()
Trace: CFtpControlSocket::ResetOperation(0)
Trace: CControlSocket::ResetOperation(0)
Status: File transfer successful

comment:2 Changed 12 years ago by Alexander Schuch

Taken from now deleted RFE:
[ 1879645 ] VMS optional inclusion of version number

"Transfers from VMS to MS Windows in version 2.2.32 stripped the version number from the file name (e.g. ABCDEF.GHI;2 -> ABSCDF.GHI). Version 3.0.5.2 retains the VMS version number. I prefer the version number be stripped from the file name, but an option to either retain or strip the version number would probably be best."

comment:3 Changed 5 years ago by Peter Hofman

Is already known when this 'feature request' will be included in a release?
Why is this after 7 years (!!!) still open? If the problem is testing against a VMS system, contact vaxman (email link on this page for an account: http://fafner.dyndns.org/).

I am currently using FileZilla Client 3.8.0 on Windows.
Me and my co-workers really want either stripping the OpenVMS version number like it was in 2.2.32, or as an option that can be configured.

I also do not agree with the fact that this is a feature request, since stripping the version number was standard behavior in version 2.2.32.
To me this is regression, so it is a bug rather than a new feature.

I agree with the comment of ci-dev: "I prefer the version number be stripped from the file name, but an option to either retain or strip the version number would probably be best."

comment:4 Changed 5 years ago by Tim Kosse

Resolution: worksforme
Status: newclosed

There's a hidden option for this. Open FileZilla.xml and set "Strip VMS revisions" to 1.

On Windows FileZilla.xml is located in the %APPDATA%/FileZilla directory.

Note: See TracTickets for help on using tickets.