Opened 16 years ago

Closed 11 years ago

#1910 closed Feature request (fixed)

Transfer many at the same time by server

Reported by: mariozavood Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc: mariozavood, olav_ouafouaf, ci-dev@…
Component version: Operating system type:
Operating system version:

Description

First of all I would like to congratulate you on the great
work you have done. I have a small proposal for a
feature enhancement you might like to consider.

In the file transfer settings, you can now set the total
number of concurrent connections. It would be nice if
you could set how many connections you can make by
server.

For instance, you could be able to configure:

Transfer up to 3 files at the same time
Maximum number of connections per server: 1

The reason is that many ftp servers limit the number of
connections from an IP address, so that many times you
cannot actually use the feature as it is implemented now.

Thanks for your time and keep up the good work!

Change History (2)

comment:1 Changed 16 years ago by olav_ouafouaf

Yes or in another way :
possibility of setting in the sit manager the number max of
connection able for each site.

IE:
If i download from to site A and B (typicaly from mirror sites)
Site A is set to accept 2 connection.
Site B is set to accept 3 Connection.
And the general seting is set to 10 simultaneous connexions.

the resulte would be 5 download (or upload) at the same time.

Thanks again for this open source work

OlaV++

comment:2 Changed 11 years ago by Alexander Schuch

Cc: ci-dev@… added
Component: UnknownFileZilla Client
Resolution: fixed
Status: newclosed

FileZilla 3 has this functionality implemented now. Please re-open this item if you have an idea on how to improve this further or if it doesn't work as intended.

Note: See TracTickets for help on using tickets.