Opened 17 years ago

Closed 10 years ago

#1629 closed Feature request (rejected)

Startup changes

Reported by: anonymous Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc: Alexander Schuch
Component version: Operating system type:
Operating system version:

Description

Can the order for startup events be changed to give
immediate user feedback. I frequently operate on a
Windows machine that has an occasional VPN connection.

There are usually 7 remote directories defined that

are only VPN reachable. When the VPN is not active,
Filezilla spends about 1 minute waiting on timeouts
before it displays anything. This leads to doubts
about whether it has been clicked properly, etc. Which
leads to double and triple starts of Filezilla and that
just makes things worse.

Possible solutions:

1) Put up a splash screen immediately. All I need is

some indication that things are starting.

2) Put up the basic Filezilla display structure, but

with neither the local nor the remote directory
information populated. That plus a cursor wait icon
would be enough to know that things are working.

3) Provide an option to eliminate partitions from the

local directory structure. This would suit my use
since I only use one partition for transfers. It might
not suit other people very well.

Creating and removing these network devices for every
startup and shutdown of the VPN is not a practical
solution. They must always be there. Windows
eventually times out when you attempt to use one when
the VPN is not running, so the problem is the long
delays from programs like Filezilla that attempt to
check every single mounted partition during startup.

Change History (1)

comment:1 Changed 10 years ago by Tim Kosse

Resolution: rejected
Status: newclosed

This is a general problem affecting all other programs. Your VPN software simply needs to unmap VPN specific resources if there is no VPN connection.

Note: See TracTickets for help on using tickets.