Opened 11 years ago

Last modified 9 years ago

#1423 closed Bug report

Port number not saving in site manager?

Reported by: carolineb Owned by:
Priority: high Component: FileZilla Client
Keywords: Cc: carolineb, Tim Kosse
Component version: Operating system type:
Operating system version:

Description

I have multiple clients using Filezilla to connect to our FTP site--my company recommends the program to them. We have had a few clients experience problems when setting up a site manager profile for our site, which needs to be accessed on port number 990. The port number does not seem to save when they exit the site manager, even though all the other settings are saved. Are they doing something wrong, or is this a bug?

Change History (3)

comment:1 Changed 11 years ago by Tim Kosse

The default port is not shown. It's the same as with URLs in your browser.

comment:2 Changed 9 years ago by Ryan J Ollos

This behavior is somewhat confusing, and it seems like it would be better to just save whatever the user entered as the port number, regardless of whether it is the default. It also might be helpful to show the default port number when the site profile is recalled, in the case that the user did not enter it when creating the profile. That is more intuitive because it would function like that most other program dialogs I have seen.

Users typically expect that if they have enter a value in a dialog and are not told via dialog that the value they entered is incorrect, that same value will still be present when they view the dialog again.

comment:3 Changed 9 years ago by Ryan J Ollos

Another idea would be to show the default port number in light gray text (rather than black), and set the default port number when the Server Type is selected, assuming the user has not entered a value.

If the user enters the default port number manually, the default port number could still be shown in light gray text when the site profile is recalled.

Note: See TracTickets for help on using tickets.