Opened 12 years ago

Last modified 12 years ago

#1375 closed Bug report

Configuration Wizard failed

Reported by: rwgibbens Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc: rwgibbens, Tim Kosse
Component version: Operating system type:
Operating system version:

Description

Using FileZillaPortable 3.0.8.1 downloaded 03/19/08 from PortableApps.com on a Toshiba Satellite P205D-S7438 running Windows Vista Home Premium 32 bit OS. Firewall is part of Windows Live One Care.
Internet connection is Qwest DSL through an ethernet hub and ActionTec DSL modem/gateway.

In the Edit/settings dialog connection section is a configuration wizard. I ran it multiple times with the same failure each time.
I chose passive transfer mode with allow fallback selected. I next selected to use the servers external IP address. On the next page I first chose to ask the operating system for the external IP address, then during test faze I got the following log:
Connecting to probe.filezilla-project.org
Response: 220 FZ router and firewall tester ready
USER FileZilla
Response: 331 Give any password.
PASS 3.0.8.1
Response: 230 logged on.
Checking for correct external IP address
IP 192.168.0.5 bjc-bgi-a-f
Response: 510 Mismatch. Your IP is 63.224.228.18, gd-cce-cci-bi
Wrong external IP address
Connection closed

I then restarted the wizard and chose to use the reported IP address of 63.224.228.18
and selected "ask operating system for a port".
Next page was the test section where we connected to probe.filezilla-project.org This was the log:
Connecting to probe.filezilla-project.org
Response: 220 FZ router and firewall tester ready
USER FileZilla
Response: 331 Give any password.
PASS 3.0.8.1
Response: 230 logged on.
Checking for correct external IP address
IP 63.224.228.18 gd-cce-cci-bi
Response: 200 OK
PREP 50472
Response: 200 Using port 50472, data token 1835879006
PORT 63,224,228,18,197,40
Response: 200 PORT command successful
LIST
Response: 150 opening data connection
Response: 503 Failure of data connection.
Server sent invalid reply.
Connection closed

The final wizard page advised me that the server sent an unrecognized reply and asked me to check for latest version (using 3.0.8.1)and submit a bug report.
This is it ;)

Is this a problem with my firewall not allowing the port connection?
I also tried selecting to use port range 6000 - 7000 (default sugestion),
and configured the firewall to allow incoming tcp/udp protocols in that port range for FileZilla.
This returned the following end message:
LIST
Response: 150 opening data connection
Connection closed

In every case there was a long pause after the "Response: 150 opening data connection" line, then failure!

The above log copies came directly from the wizard as the FileZilla client was not actively doing anything to create a message list. (I set degugging to verbose level but did not see any output)

I have loved FileZilla in the past and would really like to use it more if we can get it communicating.

Could this be a bug caused by the PortableApps modification maybe? Unlikely I'd guess, but you guys are the experts not me :)

Change History (1)

comment:1 Changed 12 years ago by Tim Kosse

This is caused by incorrect router and/or firewall configuration. The test has been designed to detect this and is working correctly.

Please read http://wiki.filezilla-project.org/Network_Configuration and configure your devices accordingly. If you can't figure it out, please contact whoever sold you the devicess.

Note: See TracTickets for help on using tickets.