Opened 12 years ago

Last modified 12 years ago

#1335 closed Bug report

Listing Directory in Passive Mode Fails.

Reported by: dznqbit Owned by:
Priority: normal Component: FileZilla Server
Keywords: Cc: dznqbit, Tim Kosse
Component version: Operating system type:
Operating system version:

Description

This occurs in FileZilla Server Beta 0.9.23
running in Windows Server 2003 R2 Service Pack 2

There appears to be some magic condition where listing a directory in passive mode will fail.

In particular: the server will transmit a partial listing and then hang up.

I have tried to isolate the condition but it seems that deleting or changing the name of even one directory from the list will allow the directory to be listed again.

Attached is a list of folder names that cause this error.

Sorry this isn't more detailed!

Attachments (1)

ftp_list.txt (3.1 KB) - added by dznqbit 12 years ago.
List of Directories

Download all attachments as: .zip

Change History (5)

Changed 12 years ago by dznqbit

Attachment: ftp_list.txt added

List of Directories

comment:1 Changed 12 years ago by Tim Kosse

Do you mean the server itself hangs so that it has to be killed and restarted?

comment:2 Changed 12 years ago by dznqbit

The server does not need to be restarted. It would just never finish listing the directory and eventually the client would disconnect.

comment:3 Changed 12 years ago by Tim Kosse

Are you using any firewalls or personal routers?

comment:4 Changed 12 years ago by sf-robot

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

Note: See TracTickets for help on using tickets.