Opened 8 months ago

Closed 8 months ago

#12969 closed Bug report (rejected)

Error with Filetype associations - Associated program not found

Reported by: Glenn Gundermann Owned by:
Priority: normal Component: FileZilla Client
Keywords: Associated program not found Cc:
Component version: 3.65.0 Operating system type:
Operating system version: Windows 11 Pro

Description

When I try to set an Active mode IP address, I get an error message saying "Associated program not found".

When I check Filetype associations, I see the following:

txt "C:\Program Files\WindowsApps\Microsoft.WindowsNotepad_11.2305.18.0_x648wekyb3d8bbwe\Notepad\Notepad.exe" %f

If I change it to this, everything works:

txt "C:\Windows\Notepad.exe" %f

Does this imply the installer has a bug?

Change History (1)

comment:1 by Tim Kosse, 8 months ago

Resolution: rejected
Status: newclosed

The issue is Microsoft. They needlessly keep changing associations and use changing opaque random identifiers in paths.

Since FileZilla is dealing with remote, potentially untrusted files, stable associations are important, you never want to accidentally open a remote file with the wrong program.

Note: See TracTickets for help on using tickets.