Opened 7 months ago

Closed 7 months ago

#12707 closed Bug report (duplicate)

Local file monitoring intermittent or not working at all. File has change doesn't work/show up

Reported by: Marko Radulovic Owned by:
Priority: normal Component: FileZilla Client
Keywords: file has change local file monitoring Cc: Marko Radulovic
Component version: 3.59.0 Operating system type: Other
Operating system version: 12.3.1

Description (last modified by Marko Radulovic)

Two days ago, I updated the FileZilla on the latest version, and the bugs with the File has change popup started immediately.

Nothing happens once I edit and save the file (from the server opened with FileZilla) in my IDE. It usually popup the File that has changed so I can click on YES and save it.

I figure it out that once I save the file, I go to FileZilla and click on Site Manager->Cancel; only then the File has change popup will appear so I can click on YES to upload the file to the server.

I'm attaching two videos on Google Drive to see the issue. In video 1.mov, you can see that nothing is happening once I save the file on IDE and go to FileZilla, and in video 2.mov, you will see what I do to trigger the File has change popup.

You can see the video on the following link: https://drive.google.com/drive/folders/1NxBe6XbJ3vRliNVV95XNgEOcHHwwjD-4?usp=sharing

I'm using the latest version of the macOS Monterey 12.3.1, PHPStorm, and FileZilla. (Also, I tried with Visual Studio Code, and the issue is still there).

This bug is giving me a hard time while I'm working. I'm hoping that you will treat this as an urgent issue.

Also, it would be great if you, in the meantime, give me the older version so I can switch it while you are working on the mentioned bug.

Thanks,
Marko

Change History (8)

comment:1 by Marko Radulovic, 7 months ago

Description: modified (diff)

comment:2 by Marko Radulovic, 7 months ago

Description: modified (diff)

comment:3 by G7ian, 7 months ago

Hello Marco,
Same problem for me !

BUT if you open the settings (for example) and close the popup, the change popup appears.
It's as if the change popup was hiding behind...

Thanks,
Gilles

comment:4 by KonsoleFaust, 7 months ago

Keywords: local monitoring added
Summary: File has change doesn't work/show upLocal file monitoring intermittent or not working at all. File has change doesn't work/show up

I'm experiencing this same issue. It seems like local file monitoring is not working correctly. The app is very delayed in responding to file changes if it responds at all. Downgrade to previous version of filezilla fixes issue.

Windows 10 FileZilla Client is 3.59.0

Last edited 7 months ago by KonsoleFaust (previous) (diff)

comment:5 by Tara Claeys, 7 months ago

Same issue for me, I am working on two Macs. One is running version 3.59.0 (most recent) and the other the previous version from 4-01-22 (3.59.0-rc1).
The most recent version 3.59.0 seems to have a bug that does not track local changes made with prompt to update/overwrite the remote file. This works properly on version 3.59.0-rc1.
Video recording showing this:
https://share.getcloudapp.com/lluEPxGP
Hoping for a fix soon!

Thanks,
Tara

comment:6 by Alex, 7 months ago

I am getting the exact same issue ever since the latest update. I've discovered that clicking on the Filezilla icon in my windows taskbar forces the popup to display.

Last edited 7 months ago by Alex (previous) (diff)

comment:8 by Tim Kosse, 7 months ago

Priority: criticalnormal
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.