Opened 5 months ago

Closed 5 months ago

Last modified 5 months ago

#12650 closed Bug report (worksforme)

Refresh button changes directory

Reported by: Thomas Klausner Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc:
Component version: 3.55.1 Operating system type: BSD
Operating system version:

Description

Wen I press the 'Refresh the file and folder lists' button for a connection where I have configured a 'default local directory', the file browser for the local side changes to display that folder. I usually do not want that, but just to reload the remote side and stay in the same directory locally.

Change History (4)

comment:1 by Tim Kosse, 5 months ago

Resolution: worksforme
Status: newclosed

Cannot reproduce. Make sure you are using the most recent version of FileZilla.

comment:2 by Thomas Klausner, 5 months ago

I can reproduce this with 3.57, and it's a problem I've been seeing for some versions.
I still can reproduce this. How do you suggest I debug this?

The configured path is on NFS and is accessed via symlinks, perhaps that is the reason?

comment:3 by Tim Kosse, 5 months ago

Please provide the exact steps necessary to reproduce.

comment:4 by Thomas Klausner, 5 months ago

I tried around a bit.
/disk/games/ is an NFS mount, when I select
/disk/games/new as the default directory, I always end up in /disk/games on refresh instead.
(Local directories work fine.)

Note: See TracTickets for help on using tickets.