#12387 closed Bug report (rejected)

Directory comparison - Different files with same size

Reported by: Filip Pynckels Owned by:
Priority: low Component: FileZilla Client
Keywords: directory comparison size Cc:
Component version: FileZilla Pro 3.52.2 Operating system type: OS X
Operating system version: OSx Cataline 10.15.7 (19H114)

Description

When

  • server contains a file with contents "abc"
  • client contains a file with contents "bac"
  • files have the same size
  • files have same date
  • files have different time

Then

  • the directory comparison view shows no difference (no colored line).

Attachments (1)

Screenshot 2021-02-16 at 13.14.40.png (250.7 KB ) - added by Filip Pynckels 10 months ago.
Printscreen FileZilla with two different files open in TextEdit

Download all attachments as: .zip

Change History (2)

by Filip Pynckels, 10 months ago

Printscreen FileZilla with two different files open in TextEdit

comment:1 by Tim Kosse, 10 months ago

Resolution: rejected
Status: newclosed

This is by design. FTP does not offer any means of comparing file contents short of completely transferring the files, in which case you could outright transfer the files skipping any comparison.

Note: See TracTickets for help on using tickets.