Opened 7 months ago

Closed 7 months ago

Last modified 7 months ago

#12305 closed Bug report (duplicate)

PROBLEM WITH TXT FILES - ADDITIONAL CR ADDED TO END OF LINE

Reported by: GEORGE SIDERIS Owned by:
Priority: normal Component: FileZilla Client
Keywords: Cc: GEORGE SIDERIS
Component version: Operating system type: Windows
Operating system version:

Description

Relates to a previous bug report that was reported 15 years ago

#1028 closed Bug report
ASCII mode transfer corrupts files nix=>win

Text Lines that end with CR LF are having an additional CR added to the line

So the the Text Line ends with CR CR LF

In Hex - CR LF (Hex 0D0A) becomes CR CR LF (Hex 0D0D0A)

I have used FileZilla for about 20 years and this has never happened to me before.

Attachments (2)

crcrlf.JPG (215.8 KB ) - added by GEORGE SIDERIS 7 months ago.
TEXT FILE CONTAING ORDER DETAILS
AL-ONA ALTONA FRESH CENTRE (SECOND AV (000373)135647.txt (26.2 KB ) - added by GEORGE SIDERIS 7 months ago.
TEXT FILE CONTAING ORDER DETAILS - WHOLE TEXT FILE

Download all attachments as: .zip

Change History (4)

by GEORGE SIDERIS, 7 months ago

Attachment: crcrlf.JPG added

TEXT FILE CONTAING ORDER DETAILS

by GEORGE SIDERIS, 7 months ago

TEXT FILE CONTAING ORDER DETAILS - WHOLE TEXT FILE

comment:1 by Tim Kosse, 7 months ago

Priority: criticalnormal
Resolution: duplicate
Status: newclosed

Duplicate of #1028, see past answer.

comment:2 by GEORGE SIDERIS, 7 months ago

I have checked out the problem using WinSCP - there is no change to the data whatsoever. All works fine.
I have used FileZilla for probably about 20 years - never had this problem until today.

You are saying that our server is adding the extra CR character - Perhaps I need to check to see what Microsoft have done to our server (2012 Server).

Very confusing - my software is now not working when it has been running for about 18 years in the same way.

Note: See TracTickets for help on using tickets.