Opened 12 years ago

Last modified 11 years ago

#1225 closed Bug report

Sended files over FTP SSL with SOCKS proxy are corrupted

Reported by: glr81 Owned by: Alexander Schuch
Priority: normal Component: FileZilla Client
Keywords: Cc: glr81, Alexander Schuch, lantrex, fedkad
Component version: Operating system type:
Operating system version:

Description

FileZilla 2.2.30
Activated proxy : SOCKS v5
Server type : FTP over SSL/TLS (implicit encryption)
Transfer type : auto
Passive mode

Sended files over a FTP SSL connection with a SOCKS proxy are corrupted.

The connection and the SSL/TLS negotiation are ok.
The upload to the server seems to be ok in the logs but actually the sended files are corrupted.
Tested with several SOCKS proxies.
No such issue without proxy or with an external SOCKS client (tested with Hummingbird).
Seems also to be ok when only downloading (retrieving) files from the FTPS server.

(Session logs attached)

Attachments (1)

fz-ftps-socks5-sendbinfile.log (3.1 KB) - added by glr81 12 years ago.
Session log sending a binary file to a FTP SSL server with a SOCKS5 proxy with Filezilla 2.2.30

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by glr81

Session log sending a binary file to a FTP SSL server with a SOCKS5 proxy with Filezilla 2.2.30

comment:2 Changed 12 years ago by fedkad

I came across the same problem:
Uploaded file truncated when using FTP over SSL and SOCKS proxy:


FileZilla (Client) version 2.2.30.
Windows XP.
Proxy settings: SOCKS4 or SOCKS5.
Servertype: FTP over SSL or TLS.

When I try to upload a file smaller that 4KB, the file becomes 0 byte-length on the server. Larger files are truncated to the nearest 4KB multiple.

No problem during download; files are transfered complete.

No problem on normal (unencrypted) FTP.

No problem on direct (no SOCKS proxy) connection.

The problem seems to occur only when using:

(1) "FTP over SSL or TLS"

AND

(2) "SOCKS4 or SOCKS5 proxy".

comment:3 Changed 11 years ago by Alexander Schuch

FileZilla 3.1.0 supports SOCKS 5 proxy now.

Can you please test if FileZilla 3.1.0 works for you in the cases described? Thanks and please report back!

comment:4 Changed 11 years ago by fedkad

The previously mentioned problem seems to have been solved in FileZilla version 3.1.0.

Thank you.

comment:5 Changed 11 years ago by Alexander Schuch

This bug has been solved in FileZilla 3.1.0, closing this bug report.

Note: See TracTickets for help on using tickets.